1. 程式人生 > >【vector傳參方法】poj 3268

【vector傳參方法】poj 3268

Description
One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.
Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.
Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?
Input

Line 1: Three space-separated integers, respectively: N, M, and X 
Lines 2..M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.
Output
Line 1: One integer: the maximum of time any one cow must walk.
Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3
Sample Output

10
Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

題意:每個農場一隻牛要去聚會地點X聚會,每隻牛去X和回家都會選擇最近的路,問所有牛中,能走的路是最長的是多少?

思路:正反各建一下邊;

程式碼:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;
#define inf 0x3f3f3f3f

const int maxn=1050;
int n,m,x;
struct Edge
{
    int v;
    int cost;
    Edge(int _v=0,int _cost=0):v(_v),cost(_cost){}
};
vector<Edge>E1[maxn],E2[maxn];
int dist1[maxn],dist2[maxn];
//void addedge(int u,int v,int w)
//{
//    E[u].push_back(Edge(v,w));
//}

bool vis[maxn];
int dist[maxn];
bool spfa(int start,int *dist,vector<Edge>E[])
{
    memset(vis,false,sizeof(vis));
    for(int i=0;i<=n;i++) dist[i]=inf;
    vis[start]=true;
    dist[start]=0;
    queue<int>que;
    while(!que.empty()) que.pop();
    que.push(start);
    while(!que.empty())
    {
        int u=que.front();
        que.pop();
        vis[u]=false;
        for(int i=0;i<(int)E[u].size();i++)
        {
            int v=E[u][i].v;
            if(dist[v]>dist[u]+E[u][i].cost)
            {
                dist[v]=dist[u]+E[u][i].cost;
                if(!vis[v])
                {
                    vis[v]=true;
                    que.push(v);
                }
            }
        }
    }
    return true;
}

int main()
{
    while(scanf("%d%d%d",&n,&m,&x)!=EOF)
    {
        int a,b,c;
        for(int i=0;i<=n;i++)
            E1[i].clear(),E2[i].clear();
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            E1[a].push_back(Edge(b,c));
        }
        spfa(x,dist1,E1);
        for(int i=1;i<=n;i++)
        {
            for(int j=0;j<(int)E1[i].size();j++)
            {
                a=i,b=E1[i][j].v,c=E1[i][j].cost;
                E2[b].push_back(Edge(a,c));
            }
        }
        spfa(x,dist2,E2);
        int maxx=0;
        for(int i=1;i<=n;i++)
        {
            if(dist1[i]+dist2[i]>maxx)
                maxx=dist1[i]+dist2[i];
        }
        printf("%d\n",maxx);
    }
    return 0;
}