juniper SRX PPPOE配置
interfaces {
fe-0/0/5 {
unit 0 {
encapsulation ppp-over-ether;
}
}
pp0 {
unit 0 {
ppp-options {
pap {
access-profile ppp-profile;
local-password "dkwoxslxqpz";##SECRET-DATA
local-name "username";
passive; ##被動模式
}
}
pppoe-options {
underlying-interface fe-0/0/5.0; 選擇介面
auto-reconnect 10; ##自動重連
client;
idle-timeout 0; ##空閒超時時間為0,就直接重新撥號
}
family inet {
negotiate-address;
mtu 1492; ##根據當地情況來設定MTU,可以不用設定
}
}
}
}
#################################
set interfaces fe-0/0/0 unit 0 encapsulation ppp-over-ether
set interfaces pp0 unit 0 ppp-options chap local-name 480000048023 這個名字要和下面的保持一致(撥號的賬號)
set interfaces pp0 unit 0 ppp-options chap no-rfc2486
set interfaces pp0 unit 0 ppp-options chap passive
set interfaces pp0 unit 0 ppp-options pap local-name 480000048023
set interfaces pp0 unit 0 ppp-options pap no-rfc2486
set interfaces pp0 unit 0 ppp-options pap local-password "$9$nrOoCORevWx7VrlJDHkPfIEcl8X"
set interfaces pp0 unit 0 ppp-options pap passive
set interfaces pp0 unit 0 pppoe-options underlying-interface fe-0/0/0.0
set interfaces pp0 unit 0 pppoe-options idle-timeout 0
set interfaces pp0 unit 0 pppoe-options auto-reconnect 3
set interfaces pp0 unit 0 pppoe-options client
set interfaces pp0 unit 0 family inet negotiate-address