1. 程式人生 > >PAT甲級1145 Hashing

PAT甲級1145 Hashing

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table first. Then try to find another sequence of integer keys from the table and output the average search time (the number of comparisons made to find whether or not the key is in the table). The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive numbers: MSize, N, and M, which are the user-defined table size, the number of input numbers, and the number of keys to be found, respectively. All the three numbers are no more than 10​4​​. Then N distinct positive integers are given in the next line, followed by M positive integer keys in the next line. All the numbers in a line are separated by a space and are no more than 10​5​​.

Output Specification:

For each test case, in case it is impossible to insert some number, print in a line X cannot be inserted. where X is the input number. Finally print in a line the average search time for all the M keys, accurate up to 1 decimal place.

Sample Input:

4 5 4
10 6 4 15 11
11 4 15 2

Sample Output:

15 cannot be inserted.
2.8

平方探測:(i*i+key)%TSize.

查詢成功:成功插入到表中或者一開始就沒有這個值(比如題目中的2);

查詢失敗:有這個值,沒有插入到hash表中 ,這個時候查詢次數應該+1.

#include <iostream>
#include <bits/stdc++.h>

using namespace std;
bool IsPrime(int num){//判斷素數
    for(int i=2; i*i<=num; i++){
        if(num % i == 0){
            return false;
        }
    }
    return true;
}

void GetTSize(int MSize, int &TSize){//獲取hash表的size
    if(MSize<=2){
        TSize = 2;
    } else{
        for(TSize = MSize; !IsPrime(TSize); TSize++);
    }
}
bool Insert(int HT[], int key, int TSize){//向hash表中插入數值
    for(int i = 0; i < TSize; i++){
        int pos = (i * i + key) % TSize;
        if(HT[pos] == -1){
            HT[pos] = key;
            return true;
        }
    }
    return false;
}
int Found(int HT[], int key, int TSize){//查詢值
    int time = 0;
    bool flag = false;
    for(int i = 0; i < TSize; i++){
        int pos = (i * i + key) % TSize;
        time++;
        if(HT[pos] == key||HT[pos] == -1){//查詢到或一開始就沒有key
            flag = true;
            break;
        }
    }
    if(!flag) time++;//有,但是沒有插入到表中
    return time;
}
int main()
{
    int MSize, M, N, TSize;
    cin>>MSize>>N>>M;
    GetTSize(MSize, TSize);
    int HT[TSize];
    memset(HT, -1, sizeof(HT));
    int key;
    for(int i=0; i<N; i++){
        cin>>key;
        if(!Insert(HT, key, TSize)){
            cout<<key<<" cannot be inserted.\n";
        }
    }

    double time = 0;
    for(int i=0; i<M; i++){
        cin>>key;
        time += Found(HT, key, TSize);
    }
    printf("%.1f\n", time/M);
    return 0;
}