1. 程式人生 > >1016 Phone Bills ( vector的使用)

1016 Phone Bills ( vector的使用)

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line

record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

思路:
  1、由於輸入資料中有的不適合,所以首先要做資料預處理才能進行計算
2、在輸入資料中,掛電話的時間有可能在打電話時間之前,所以只能是把輸入資料存到一個vector中,然後先按名字再按時間進行排序,
  前後相鄰專案即為匹配的記錄
  3、在計算dollar的時候採用了相減的方法。
#include<iostream>
#include<sstream>
#include<algorithm>
#include<map>
#include<cmath>
#include<cstdio>
#include<string.h>
#include<queue>
#include<vector>
using namespace std;

struct Node
{
    string name;
    int month;
    int day;
    int hour;
    int minute;
    long long int time;
    int state;
};

struct Data
{
    Node startTime;
    Node endTime;
};

bool cmp(Node &a,Node &b)
{
    return a.name!=b.name?a.name<b.name:a.time<b.time;
}


int fees[25];

double compute(Node node)
{
    double dollars=0;
    dollars+=node.day*fees[24];
    int i=0;
    for(i=0;i<node.hour;i++)
    {
        dollars+=fees[i]*60;
    }
    return (dollars+node.minute*fees[i])/100;
}

int main()
{
    for(int i=0;i<24;i++)
    {
        cin>>fees[i];
        fees[24]+=fees[i]*60;
    }
    int n;
    cin>>n;
    vector<Node> node(n);
    for(int i=0;i<n;i++)
    {
        char c;
        cin>>node[i].name>>node[i].month>>c>>node[i].day>>c;
        cin>>node[i].hour>>c>>node[i].minute;
        //cout<<node[i].name<<" "<<node[i].month<<" "<<node[i].minute<<endl;
        node[i].time=node[i].day*24*60+node[i].hour*60+node[i].minute;
        string state;
        cin>>state;
        node[i].state=(state=="on-line")?1:0;
    }
    sort(node.begin(),node.end(),cmp);
    map<string,vector<Node>> custom;
    for(int i=1;i<n;i++)
    {
        if(node[i-1].name==node[i].name&&node[i-1].state==1&&node[i].state==0)
        {
           // cout<<node[i-1].name<<" abc"<<endl;
            custom[node[i].name].push_back(node[i-1]);
            custom[node[i].name].push_back(node[i]);

        }
    }
    //double dollars,total=0;
    for(auto it:custom)
    {
        vector<Node> node=it.second;
        cout<<it.first<<" ";
        printf("%02d\n",node[0].month);
        double total=0;
        for(int i=1;i<node.size();i+=2)
        {
            printf("%02d:%02d:%02d ",node[i-1].day,node[i-1].hour,node[i-1].minute);
            printf("%02d:%02d:%02d %d ",node[i].day,node[i].hour,node[i].minute,node[i].time-node[i-1].time);
            //cout<<"Total amount: ";
            double dollars=(compute(node[i])-compute(node[i-1]));
            total+=dollars;
            printf("$%.2f\n",dollars);
        }
        cout<<"Total amount: ";
        printf("$%.2f\n",total);
    }
    return 0;
}