1152 Google Recruitment (20 分)【簡單題】
In July 2004, Google posted on a giant billboard along Highway 101 in Silicon Valley (shown in the picture below) for recruitment. The content is super-simple, a URL consisting of the first 10-digit prime found in consecutive digits of the natural constant e. The person who could find this prime number could go to the next step in Google's hiring process by visiting this website.
The natural constant e is a well known transcendental number(超越數). The first several digits are: e = 2.718281828459045235360287471352662497757247093699959574966967627724076630353547594571382178525166427427466391932003059921... where the 10 digits in bold are the answer to Google's question.
Now you are asked to solve a more general problem: find the first K-digit prime in consecutive digits of any given L-digit number.
Input Specification:
Each input file contains one test case. Each case first gives in a line two positive integers: L (≤ 1,000) and K (< 10), which are the numbers of digits of the given number and the prime to be found, respectively. Then the L-digit number N is given in the next line.
Output Specification:
For each test case, print in a line the first K-digit prime in consecutive digits of N. If such a number does not exist, output 404
instead. Note: the leading zeroes must also be counted as part of the K digits. For example, to find the 4-digit prime in 200236, 0023 is a solution. However the first digit 2 must not be treated as a solution 0002 since the leading zeroes are not in the original number.
Sample Input 1:
20 5
23654987725541023819
Sample Output 1:
49877
Sample Input 2:
10 3
2468024680
Sample Output 2:
404
題意:給定n和k,n表示要輸入的資料的長度,k表示在輸入的資料中找出長度為k的素數(第一次出現),找到輸出這個素數,如果沒有輸出404。
解題思路:直接模擬,在主函式外寫一個判斷是否是素數的函式,輸入的資料很大,所以用字串處理,素數的個位基本上是奇數,除了2,但題目說了可以有前導0,所以我們還要考慮個位是2的情況,在字串找到奇數,然後往前去k個,組成一個字串,將其轉化成整數,然後呼叫素數判斷函式,找到輸出這個字串,找不著就輸出404。這個思路知道 後,小可愛自己再敲,不要看下面的程式碼,不會再看下面的程式碼。
//自己敲的
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
bool judge(ll a)
{
if(a==1) return false;
for(int i=2;i<=sqrt(a);i++)
{
if(a%i==0) return false;
}
return true;
}
int main(void)
{
string s,s1;
int k,i,n;
cin>>n>>k;
cin>>s;
int len=s.length();
for(i=k;i<=len;i++)
{
s1="";
if((s[i-1]-48)%2==1||s[i-1]-48==2)
{
for(int j=i-k;j<=i-1;j++)
s1+=s[j];
ll b=stoll(s1);
if(judge(b))
{
cout<<s1<<endl;
break;
}
}
}
if(i>len) cout<<"404"<<endl;
return 0;
}
下面柳婼學姐非常簡潔的程式碼:https://blog.csdn.net/liuchuo/article/details/84973085
#include <iostream>
#include <string>
using namespace std;
bool isPrime(int n) {
if (n == 0 || n == 1) return false;
for (int i = 2; i * i <= n; i++)
if (n % i == 0) return false;
return true;
}
int main() {
int l, k;
string s;
cin >> l >> k >> s;
for (int i = 0; i <= l - k; i++) {
string t = s.substr(i, k);
int num = stoi(t);
if (isPrime(num)) {
cout << t;
return 0;
}
}
cout << "404\n";
return 0;
}