1. 程式人生 > >思科常用命令

思科常用命令

操作模式

  1. 使用者模式。提示符:">",進入命令:初始模式。
  2. 特權模式。提示符:"#",進入命令:enable 退出命令:disable
  3. 全域性配置模式。提示符:"(config)#",進入命令:configure terminal 退出命令:exit
  4. 其他配置模式。如介面模式:提示符:"(config-if)#",進入:interface type number 退出:exit

常用命令

設定系統日曆:R1#clock set 8:43:00 12 june 2008
       R1(config)#clock timezone GMT +8 (設定時區為北京時間東八區)

命令列幫助:任何情況輸入“?”獲取幫助。
測試網路連通性:ping ip地址
測試中間經過裝置:traceroute ip地址

檢視硬體軟體資訊:R1>show version
檢視執行配置檔案:R1# show run
檢視儲存的配置檔案:R1# show startup-config
檢視介面狀態: R1# show interface
檢視介面與IP相關的資訊:R1# show ip interface
       R1# show ip interface brief
檢視路由表:R1# show ip route
檢視路由協議:R1# show ip protocols
配置儲存:


儲存執行配置檔案:R1# copy running-config startup
       或者R1# write(用執行配置檔案覆蓋啟動配置檔案)
刪除啟動配置檔案:R1#erase startup-config


配置路由器

配置路由器密碼:
(1)配置Console埠密碼:
   R1(config)# line console 0
   R1(config-line)# password cisco
   R1(config-line)# login
(2)配置從使用者模式切換到特權模式的使能密碼:
   R1(config)# enable password cisco
   R1(config)# enable secret cisco123 (另外可以配置祕密使能密碼)
(3)配置遠端登入密碼(VTY,虛擬終端型別)預設不允許遠端訪問
   R1(config)#line vty 0 4
   R1(config-line)#password cisco
   R1(config-line)#login

配置路由器介面IP:
R1(config)# interface s1/1
R1(config-if)# ip address 12.1.1.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# exit
配置路由器介面secondary地址:
R1(config)# interface s1/1
R1(config-if)# ip address 12.1.1.1 255.255.255.0
R1(config-if)# ip address 13.1.1.1 255.255.255.0 secondary
R1(config-if)# no shutdown
R1(config-if)# exit
取消介面的多個IP地址:R1(config-if)# no ip address [ip] [子網掩碼]
刪除介面下的所有IP:R1(config-if)# no ip address

配置主機名列表:
R1(config)#ip host abc 12.1.1.2 (配置完後遠端登入可以用telnet abc代替主機IP)
檢視路由器上配置的主機名列表: show host
配置DNS伺服器:ip name-server dns 伺服器的IP地址

配置靜態路由
R1(config)#ip route 目標網路 掩碼 下一跳路由器直連線口的IP或本路由器外出介面 管理距離 [permanent]
使用permanent引數,不管發生什麼意外情況,該靜態路由不會從路由表消失。
前面加no刪除該靜態路由。

預設路由:用來轉發不在路由列表中列出的遠端目的網路的資料包
R1(config)#ip route 0.0.0.0 0.0.0.0 下一跳路由地址

動態路由
1. RIPv1協議配置
R1(config)# router rip  啟動路由選擇程序
R1(config-router)#network 11.0.0.0  宣告各介面的直連網路
R1(config-router)#network 12.0.0.0

配置預設路由(預設閘道器):R1(config)# ip route 0.0.0.0 0.0.0.0 23.1.1.3
             R1(config)# ip default-network 23.0.0.0  預設網路,僅支援有類網路後面要寫網路的主類地址

負載均衡:R1(config-router)#maximum-paths 6
關閉快速交換使用程序交換:R1(config)#no ip cef

禁用水平分割:R1(config-if)# no ip split-horizon


2. RIPv2協議配置
R1(config)# router rip
R1(config-router)# version 2
R1(config-router)#network 主類網路號


3. OSPF協議配置
R1(config)#router ospf 1
R1(config-router)#network IP子網 反掩碼 area 0


配置DHCP伺服器

R1(config)#ip dhcp excluded-address 192.168.1.1 把閘道器排出地址池
R1(config)#ip dhcp pool poolname 配置DHCP地址池名字
R1(dhcp-config)#network 192.168.1.0/24 分配網段地址
R1(dhcp-config)#default-router 192.168.1.1 指定閘道器
R1(dhcp-config)#dns-server 202.102.3.141 指定DNS伺服器
R1(dhcp-config)#lease 8 IP地址租期是8天,預設無限期
R1(dhcp-config)#domain-name test.com 設定主機域名,可不設此項
R1(dhcp-config)#exit

配置DHCP中繼:
R3(config)#int fa 0/0 配置與DHCP客戶端最近的乙太網介面
R3(config-if)#ip helper-address 23.1.1.2 把收到的DHCP廣播包裝發給DHCP伺服器23.1.1.2

常用:ipconfig/release釋放先前獲取的IP
  ipconfig/renew重新獲取IP


配置NAT

配置靜態NAT:
(1) 指定外部埠。埠設定狀態下輸入:ip nat outside
(2) 指定內部埠。埠設定狀態下輸入:ip nat inside
(3) 在內部本地地址與內部合法地址之間建立靜態地址轉換。全域性配置狀態下輸入:
ip nat inside source static 內部本地地址 內部合法地址

配置動態NAT:
(1) 指定外部埠。埠設定狀態下輸入:ip nat outside
(2) 指定內部埠。埠設定狀態下輸入:ip nat inside
(3) 全域性配置模式下定義內部合法地址池:ip nat pool 地址池名稱 起始IP地址 終止IP地址 子網掩碼
(4) 全域性配置模式下定義一個access-list規則以允許哪些內部地址可以進行動態地址轉換:
access-list 表號 permit 源地址 萬用字元
(5) 全域性配置模式下,將由access-list指定的內部本地地址與內部合法地址池進行地址轉換:
ip nat inside source list ACL表號 pool 內部合法地址池名字 [overload] 加上overload引數表示配置NAT超載

**配置埠對映:
將外網對218.1.1.1的TCP80埠的訪問轉換成對內部IP192.168.1.1的80埠訪問:
**R1(config)#ip nat inside source static tcp 192.168.1.1 80 218.1.1.1 80
外網端為動態IP時的NAT配置:
R1(config)#ip nat inside source list 1 int fa0/0 overload 不用建立地址池,直接借用介面fa0/0的IP,預設路由還是需要配的


交換機基本配置

配置預設閘道器:SW1(config)# ip default-gateway 1.1.1.1

開啟http服務:SW1(config)# ip http server
關閉http服務:SW1(config)#no ip http server

檢視ARP表:show arp
檢視MAC地址表:show mac-address-table

vlan配置:參考思科交換機VLAN配置
檢視vlan:show vlan

訪問控制列表ACL:參考思科交換機ACL配置