1. 程式人生 > >poj 1511 spfa 模板題

poj 1511 spfa 模板題

Invitation Cards
Time Limit: 8000MS Memory Limit: 262144K
Total Submissions: 26478 Accepted: 8790

Description

In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special course was taken where students learned how to influence people and what is the difference between influencing and robbery. 

The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait until the next full half an hour, e.g. X:00 or X:30, where 'X' denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan. 

All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program that helps ACM to minimize the amount of money to pay every day for the transport of their employees. 

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop.

Output

For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers.

Sample Input

2
2 2
1 2 13
2 1 33
4 6
1 2 10
2 1 60
1 3 20
3 4 10
2 4 5
4 1 50

Sample Output

46
210

Source

edge[i].to表示第i條邊的終點,edge[i].next表示與第i條邊同起點的下一條邊的儲存位置,edge[i].w為邊權值.

另外還有一個數組head[],它是用來表示以i為起點的第一條邊儲存的位置,實際上你會發現這裡的第一條邊儲存的位置其實

在以i為起點的所有邊的最後輸入的那個編號.

head[]陣列一般初始化為-1,對於加邊的add函式是這樣的:

  1. void add(int u,int v,int w)  
  2. {  
  3.     edge[cnt].w = w;  
  4.     edge[cnt].to = v;  
  5.     edge[cnt].next = head[u];  
  6.     head[u] = cnt++;  
  7. }  

#include <cstdio>
#include <iostream>
#include <map>
#include <cmath>
#include <queue>
using namespace std;
const int MAXN = 1000005;
const int inf = 0x3f3f3f3f;
typedef long long LL;
int head[2][MAXN];
bool vis[MAXN];
LL dist[MAXN];
struct node{
    int to, next, w;
} edge[2][MAXN];
int n, m;
void spfa(int cur)
{
    int v, i, b;//v為以v編號為起點

    queue <int> q;
    for(int i = 1; i<=n; ++i)
    {
        vis[i] = false;
        dist[i] = inf;
    }
    while(!q.empty())
        q.pop();
    q.push(1);
    vis[1] = 1;
    dist[1] = 0;
    while(!q.empty())
    {
        v = q.front();
        q.pop();
        vis[v] = 0;
        for(i = head[cur][v]; ~i; i=edge[cur][i].next)//head[cur][v]就是v為起點的對應第幾條邊,若不為-1則存在到其他點的路徑
        {
   //這裡的i是以v為起點,邊的編號            

b = edge[cur][i].to;//從編號最大的終點開始,初始化時的i和head【a】=i中的i相等。
            if(dist[b]>dist[v] + edge[cur][i].w)//以起點為v初始化時的,終點為i
            {
                dist[b] = dist[v] + edge[cur][i].w;
                if(!vis[b])
                {
                    vis[b] = true;
                    q.push(b);
                }
            }
        }
    }
}
int main()
{
    int t;
    int a, b, w;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d %d", &n, &m);
        for(int i = 1; i<=n; ++i)
        {
            head[0][i] = -1;
            head[1][i] = -1;
        }
        for(int i = 0; i<m; ++i)
        {
            scanf("%d %d %d", &a, &b, &w);
            edge[0][i].w = w;
            edge[0][i].to = b;
            edge[0][i].next = head[0][a];
            head[0][a] = i;
            edge[1][i].w = w;
            edge[1][i].to = a;
            edge[1][i].next = head[1][b];
            head[1][b] = i;
        }
        LL ans = 0;
        spfa(0);
        for(int i = 1; i<=n; ++i) ans += dist[i];
        spfa(1);
        for(int i = 1; i<=n; ++i) ans += dist[i];
        printf("%lld\n", ans);
    }
    return 0;
}