1. 程式人生 > >1698 Just a Hook —— 區間更新 區間查詢

1698 Just a Hook —— 區間更新 區間查詢

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 35460    Accepted Submission(s): 17322


Problem Description In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

Input The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

Output For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

Sample Input 1 10 2 1 5 2 5 9 3
Sample Output Case 1: The total value of the hook is 24.

題意:有一個線段 被分成等長的n段 每一段最開始都是銅的 每次可以把某個區間裡的材質改成銀的或者金的 最後問整個線段的總價值

思路:線段樹的區間更新 在樹節點中設定一個lazy標籤 表示這個區間被更新過 同時改變記錄區間價值的值 每次遇到lazy標籤就把它向下更新

#include <iostream>
#include <cstdio>
#include <cstring>
#define max_ 100010
using namespace std;
struct node
{
	int l,r,tag,sum,lazy;
};
struct node tree[max_*4];
int n,q;
void built(int i,int l,int r)
{
	tree[i].l=l;
	tree[i].r=r;
	tree[i].lazy=0;
	tree[i].tag=1;
	if(l==r)
	{
		tree[i].sum=1;
		return;
	}
	int mid=(l+r)>>1;
	built(i<<1,l,mid);
	built(i<<1|1,mid+1,r);
	tree[i].sum=tree[i<<1].sum+tree[i<<1|1].sum;
}
void change(int i,int l,int r,int v)
{
	if(tree[i].l==l&&tree[i].r==r)
	{
		tree[i].lazy=1;
		tree[i].tag=v;
		tree[i].sum=v*(r-l+1);
		return;
	}
	int mid=(tree[i].l+tree[i].r)>>1;
	if(tree[i].lazy)
	{
		tree[i].lazy=0;
		change(i<<1,tree[i].l,mid,tree[i].tag);
		change(i<<1|1,mid+1,tree[i].r,tree[i].tag);
		tree[i].tag=0;
	}
	if(l>mid)
		change(i<<1|1,l,r,v);
	else if(r<=mid)
		change(i<<1,l,r,v);
	else
	{
		change(i<<1,l,mid,v);
		change(i<<1|1,mid+1,r,v);
	}
	tree[i].sum=tree[i<<1].sum+tree[i<<1|1].sum;
}
int main(int argc, char const *argv[])
{
	int r,t;
	scanf("%d",&t);
	for(r=1;r<=t;r++)
	{

		scanf("%d%d",&n,&q);
		built(1,1,n);
		while(q--)
		{
			int a,b,c;
			scanf("%d%d%d",&a,&b,&c);
			change(1,a,b,c);
		}
		printf("Case %d: The total value of the hook is %d.\n",r,tree[1].sum);
	}
	return 0;
}