1. 程式人生 > >POJ2636 HDU2304 ZOJ2807 Electrical Outlets【水題】

POJ2636 HDU2304 ZOJ2807 Electrical Outlets【水題】

Electrical Outlets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9987 Accepted: 7458

Description

Roy has just moved into a new apartment. Well, actually the apartment itself is not very new, even dating back to the days before people had electricity in their houses. Because of this, Roy's apartment has only one single wall outlet, so Roy can only power one of his electrical appliances at a time.
Roy likes to watch TV as he works on his computer, and to listen to his HiFi system (on high volume) while he vacuums, so using just the single outlet is not an option. Actually, he wants to have all his appliances connected to a powered outlet, all the time. The answer, of course, is power strips, and Roy has some old ones that he used in his old apartment. However, that apartment had many more wall outlets, so he is not sure whether his power strips will provide him with enough outlets now.
Your task is to help Roy compute how many appliances he can provide with electricity, given a set of power strips. Note that without any power strips, Roy can power one single appliance through the wall outlet. Also, remember that a power strip has to be powered itself to be of any use.
在這裡插入圖片描述

Input

Input will start with a single integer 1 <= N <= 20, indicating the number of test cases to follow. Then follow N lines, each describing a test case. Each test case starts with an integer 1 <= K <= 10, indicating the number of power strips in the test case. Then follow, on the same line, K integers separated by single spaces, O1 O2 . . . OK, where 2 <= Oi <= 10, indicating the number of outlets in each power strip.

Output

Output one line per test case, with the maximum number of appliances that can be powered.

Sample Input

3
3 2 3 4
10 4 4 4 4 4 4 4 4 4 4
4 10 10 10 10

Sample Output

7
31
37

Source

新增連結描述Nordic 2005

問題連結POJ2636 HDU2304 ZOJ2807 Electrical Outlets
問題簡述:(略)
問題分析
    k個電插排,有關各自的插孔數量,問連在一起還剩下多少插孔?
    k個電插排連在一起需要用掉k-1個插孔。求和就算一下就可以了。
程式說明

:(略)
參考連結:(略)
題記:(略)

AC的C語言程式如下:

/* POJ2636 HDU2304 ZOJ2807 Electrical Outlets */

#include <stdio.h>

int main(void)
{
    int n, k, a, ans;
    scanf("%d", &n);
    while(n--) {
        scanf("%d", &k);

        ans = -(k - 1);
        while(k--) {
            scanf("%d", &a);
            ans += a;
        }

        printf("%d\n", ans);
    }

    return 0;
}