PAT (Advanced Level) Practice 1077 Kuchiguse (20 分)(C++)(甲級)
1077 Kuchiguse (20 分)
The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker’s personality. Such a preference is called “Kuchiguse” and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle “nyan~” is often used as a stereotype for characters with a cat-like personality:
Itai nyan~ (It hurts, nyan~)
Ninjin wa iyada nyan~ (I hate carrots, nyan~)
Now given a few lines spoken by the same character, can you find her Kuchiguse?
Input Specification:
Each input file contains one test case. For each case, the first line is an integer N (2≤N≤100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character’s spoken line. The spoken lines are case sensitive.
Output Specification:
For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai.
Sample Input 1:
3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~
Sample Output 1:
nyan~
Sample Input 2:
3
Itai!
Ninjinnwaiyada T_T
T_T
Sample Output 2:
nai
using namespace std;
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>
string str, kuchiguse;
int main()
{
int N = 0;
scanf("%d", &N);
getchar();
getline(cin, kuchiguse);//輸入第一個字串,最長字尾必是第一個字串的子串
int len1 = kuchiguse.size();//PAT不能用gets,只好用getline了
int i, j, k, flag = 0;
for (i = 1; i < N; i++)
{
getline(cin, str);//剩下的字串用來和第一和匹配
int len2 = str.size();
for (j = len1 - 1, k = len2 - 1; j >= flag && k >= 0; j--, k--)
{
if (kuchiguse[j] != str[k]) break;//不匹配則跳出
}
flag = j + 1;//flag標記最長公共字尾字第一個字元所在位置
}
if (flag < len1)//若存在公共子串則列印輸出
{
while (flag < len1) printf("%c", kuchiguse[flag++]);
}
else printf("nai");//否則輸出“奈~” 大概是日語沒有的意思吧hhhhhhhh
return 0;
}