1. 程式人生 > >PAT (Advanced Level) Practice 1035 Password (20 分)(C++)(甲級)

PAT (Advanced Level) Practice 1035 Password (20 分)(C++)(甲級)

1035 Password (20 分)

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa
Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 [email protected]
Sample Input 2:

1
team110 abcdefg332
Sample Output 2:

There is 1 account and no account is modified
Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333
Sample Output 3:

There are 2 accounts and no account is modified


#include <cstdio>
#include <cstring>
#include <cmath>

typedef struct Record
{
    char name[20];
    char passwords[20];
    bool modified;//是否修正標誌變數
}Record;

Record S[1010] = {0};

int main()
{
    int N = 0, i = 0, cnt = 0;
    scanf("%d", &N);
    for(i=0; i<N; i++)
    {
        scanf("%s %s", S[i].name, S[i].passwords);
        int len = strlen(S[i].passwords);
        for(int j=0; j<len; j++)//遍歷,若修正則置標誌
        {
            if(S[i].passwords[j] == '1') S[i].passwords[j] = '@', S[i].modified = 1;
            if(S[i].passwords[j] == '0') S[i].passwords[j] = '%', S[i].modified = 1;
            if(S[i].passwords[j] == 'l') S[i].passwords[j] = 'L', S[i].modified = 1;
            if(S[i].passwords[j] == 'O') S[i].passwords[j] = 'o', S[i].modified = 1;
        }
        if(S[i].modified) cnt++;//並計數
    }
    if(!cnt)
    {
        if(N<=1) printf("There is %d account and no account is modified", N);//注意單複數差別
        else printf("There are %d accounts and no account is modified", N);
    }
    else
    {
        printf("%d\n", cnt);//cnt為0是不需要輸出這句話的
        for(i=0; i<N; i++)
        {
            if(S[i].modified)//把修正後的紀錄輸出
            {
                printf("%s %s\n", S[i].name, S[i].passwords);
            }
        }
    }
	return 0;
}