1. 程式人生 > >杭電 2004 成績轉換

杭電 2004 成績轉換

成績轉換

Problem Description
輸入一個百分制的成績t,將其轉換成對應的等級,具體轉換規則如下:
90~100為A;
80~89為B;
70~79為C;
60~69為D;
0~59為E;

Input
輸入資料有多組,每組佔一行,由一個整陣列成。

Output
對於每組輸入資料,輸出一行。如果輸入資料不在0~100範圍內,請輸出一行:“Score is error!”。

Sample Input
56
67
100
123

Sample Output
E
D
A
Score is error!

題目分析

基礎題

程式碼

#include<stdio.h>
int main()
{
	int score;
	while(scanf("%d",&score)!=EOF){
		if(score>=90&&score<=100) printf("A\n");
		else if(score>=80&&score<=89) printf("B\n");
		else if(score>=70&&score<=79) printf("C\n");
		else if(score>=60&&score<=69) printf("D\n");
		else if(score>=0&&score<=59) printf("E\n");
		else  printf("Score is error!\n");
	                              }
	return 0;
}