1. 程式人生 > >UVA1167Hardwood Species字典樹 統計詞頻

UVA1167Hardwood Species字典樹 統計詞頻

https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=1167

Hardwoods are the botanical group of trees that have broad leaves, produce a fruit or nut, and generally go dormant in the winter. America’s temperate climates produce forests with hundreds of hardwood species —trees that share certain biological characteris- tics. Although oak, maple and cherry all are types of hardwood trees, for example, they are different species. Together, all the hard- wood species represent 40 percent of the trees in the United States. On the other hand, softwoods, or conifers, from the Latin word meaning “cone-bearing”, have needles. Widely available US soft- woods include cedar, fir, hemlock, pine, redwood, spruce and cy- press. In a home, the softwoods are used primarily as structural lumber such as 2×4s and 2×6s, with some limited decorative appli- cations. Using satellite imaging technology, the Department of Natural Resources has compiled an inventory of every tree standing on a particular day. You are to compute the total fraction of the tree population represented by each species. Input The first line is the number of test cases, followed by a blank line. Each test case of your program consists of a list of the species of every tree observed by the satellite; one tree per line. No species name exceeds 30 characters. There are no more than 10,000 species and no more than 1,000,000 trees. There is a blank line between each consecutive test cases. Output For each test case print the name of each species represented in the population, in alphabetical order, followed by the percentage of the population it represents, to 4 decimal places. Print a blank line between 2 consecutive test cases. Sample Input 1 Red Alder Ash Aspen Basswood Ash Beech Yellow Birch Ash Cherry Cottonwood Ash Cypress Red Elm Gum Hackberry White Oak Hickory Pecan Hard Maple White Oak Soft Maple Red Oak Red Oak White Oak Poplan Sassafras Sycamore Black Walnut Willow Sample Output Ash 13.7931 Aspen 3.4483 Basswood 3.4483 Beech 3.4483 Black Walnut 3.4483 Cherry 3.4483 Cottonwood 3.4483 Cypress 3.4483 Gum 3.4483 Hackberry 3.4483 Hard Maple 3.4483 Hickory 3.4483 Pecan 3.4483 Poplan 3.4483 Red Alder 3.4483

 

#include <iostream>
#include <stdio.h>
#define MAX 256
using namespace std;
struct trie
{
    int num;//單詞數
    trie *next[MAX];
};
trie *root=new trie;
char words[40];
int sum;
 
void insert_trie(char *str)
{
    trie *p,*newnode;
    p=root;
    for(int i=0; str[i]!='\0'; i++)
    {
        if(p->next[(int)str[i]]==NULL)
        {
            newnode=new trie;//
            //因為什麼字元都有,就不用其減去某個字元當做位置了
            //而是直接(int)str[i];
            for(int j=0; j<MAX; j++)
                newnode->next[j]=NULL;
            newnode->num=0;
            p->next[(int)str[i]]=newnode;
            p=newnode;
        }
        else
        {
            p=p->next[(int)str[i]];
        }
    }
    p->num++;//單詞數加一
    sum++;//所有單詞個數加一;
}
 
void dfs(trie *p,int cur)
{
    for(int i=0; i<MAX; i++)
    {
 
        if(p->next[i]!=NULL)
        {
            words[cur]=(char)i;//儲存字元,不斷累加;
            if(p->next[i]->num!=0)//如果變成了個單詞的話
            {
                words[cur+1]='\0';//結束符
                printf("%s %.4f\n",words,(double)p->next[i]->num/(double)sum*100);
                p->num=0;//輸出並賦值為0
            }
            dfs(p->next[i],cur+1);//搜尋下一個單詞;
        }
    }
}
 
 
int main()
{
    int i;
    for(i=0; i<MAX; i++)
        root->next[i]=NULL;//下一個節點;
    root->num=0;
    sum=0;
    while(gets(words))
    {
        insert_trie(words);
        //printf("sum=%d\n",sum);
    }
    dfs(root,0);//按字典序輸出!
    return 0;
}