POJ2155:Matrix(二維樹狀陣列,經典)
阿新 • • 發佈:2019-01-23
Description
Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.
1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
2. Q x y (1 <= x, y <= n) querys A[x, y].
Input
The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above.
Output
There is a blank line between every two continuous test cases.
Sample Input
1 2 10 C 2 1 2 2 Q 2 2 C 2 1 2 1 Q 1 1 C 1 1 2 1 C 1 2 1 2 C 1 1 2 2 Q 1 1 C 1 1 2 1 Q 2 1
Sample Output
1 0 0 1
Source
這道題確實很經典,尤其在這個二進位制的計算方面 詳細的可以參考《淺談資訊學競賽中的“0”和“1”》此論文,網上很多說的並不詳細,大多隻介紹了翻轉,並沒有介紹為何sum(x,y)%2能得到結果#include <iostream>
#include <stdio.h>
#include <string.h>
#include <string>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <math.h>
#include <bitset>
#include <list>
#include <algorithm>
#include <climits>
using namespace std;
#define lson 2*i
#define rson 2*i+1
#define LS l,mid,lson
#define RS mid+1,r,rson
#define UP(i,x,y) for(i=x;i<=y;i++)
#define DOWN(i,x,y) for(i=x;i>=y;i--)
#define MEM(a,x) memset(a,x,sizeof(a))
#define W(a) while(a)
#define gcd(a,b) __gcd(a,b)
#define LL long long
#define N 1005
#define INF 0x3f3f3f3f
#define EXP 1e-8
#define lowbit(x) (x&-x)
const int mod = 1e9+7;
int c[N][N],n,m,cnt,s,t;
int a[N][N];
int sum(int x,int y)
{
int ret = 0;
int i,j;
for(i = x;i>=1;i-=lowbit(i))
{
for(j = y;j>=1;j-=lowbit(j))
{
ret+=c[i][j];
}
}
return ret;
}
void add(int x,int y)
{
int i,j;
for(i = x;i<=n;i+=lowbit(i))
{
for(j = y;j<=n;j+=lowbit(j))
{
c[i][j]++;
}
}
}
int main()
{
int i,j,x,y,ans,t;
int x1,x2,y1,y2;
char op[10];
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
MEM(c,0);
MEM(a,0);
while(m--)
{
scanf("%s",op);
if(op[0]=='C')
{
scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
x1++,y1++,x2++,y2++;
add(x2,y2);
add(x1-1,y1-1);
add(x2,y1-1);
add(x1-1,y2);
}
else
{
scanf("%d%d",&x1,&y1);
x2 = x1,y2 = y1;
x1++,y1++,x2++,y2++;
printf("%d\n",sum(x1,y1));
}
}
printf("\n");
}
return 0;
}