Triangle Partition(構建三角形)
題目連結
Problem Description
Chiaki has 3n points p1,p2,…,p3n. It is guaranteed that no three points are collinear.
Chiaki would like to construct n disjoint triangles where each vertex comes from the 3n points.
Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤1000) – the number of triangle to construct.
Each of the next 3n lines contains two integers xi and yi (−109≤xi,yi≤109).
It is guaranteed that the sum of all n does not exceed 10000.
Output
For each test case, output n lines contain three integers ai,bi,ci (1≤ai,bi,ci≤3n) each denoting the indices of points the i-th triangle use. If there are multiple solutions, you can output any of them.
Sample Input
1
1
1 2
2 3
3 5
Sample Output
1 2 3
題意分析:
給出3n個點,讓你構造n個三角形,然後輸出ai,bi,ci,表示三角形對應三個點的編號。
因為題上說沒有任意三個點是共線的,所以直接排序輸出即可。
程式碼篇:
#include <iostream>
#include <algorithm>
using namespace std;
struct Triangle
{
int x,y,id;
}a[10010];
bool cmp(Triangle A,Triangle B)//按橫座標排序
{
return A.x<B.x;
}
int main()
{
int t,n,i,j;
cin >> t;
while(t--)
{
cin >> n;
for(i=1; i<=3 *n; i++)
{
a[i].id=i;
cin >> a[i].x >> a[i].y;
}
sort(a+1,a+3*n+1,cmp);//存的時候是從第一個開始的,排序也要注意
for(i=1; i<=3*n; i+=3)
cout << a[i].id << " " << a[i+1].id << " " << a[i+2].id << endl;
}
return 0;
}