1. 程式人生 > >POJ 1077 Eight

POJ 1077 Eight

Description

The 15-puzzle has been around for over 100 years; even if you don't know it by that name, you've seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let's call the missing tile 'x'; the object of the puzzle is to arrange the tiles so that they are ordered as:
 1  2  3  4 

 5  6  7  8 

 9 10 11 12 

13 14 15  x 

where the only legal operation is to exchange 'x' with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle:
 1  2  3  4    1  2  3  4    1  2  3  4    1  2  3  4 

 5  6  7  8    5  6  7  8    5  6  7  8    5  6  7  8 

 9  x 10 12    9 10  x 12    9 10 11 12    9 10 11 12 

13 14 11 15   13 14 11 15   13 14  x 15   13 14 15  x 

           r->           d->           r-> 

The letters in the previous row indicate which neighbor of the 'x' tile is swapped with the 'x' tile at each step; legal values are 'r','l','u' and 'd', for right, left, up, and down, respectively.

Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and
frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing 'x' tile, of course).

In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three
arrangement.

Input

You will receive a description of a configuration of the 8 puzzle. The description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus 'x'. For example, this puzzle
 1  2  3 

 x  4  6 

 7  5  8 

is described by this list:
 1 2 3 x 4 6 7 5 8 

Output

You will print to standard output either the word ``unsolvable'', if the puzzle has no solution, or a string consisting entirely of the letters 'r', 'l', 'u' and 'd' that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line.

Sample Input

 2  3  4  1  5  x  7  6  8 

Sample Output

ullddrurdllurdruldr
  類似於拼圖遊戲,九格拼圖怎樣才能按順序拼出來。
  剛看這道題時,我並沒有覺得它很難,甚至比之前簡單直接搜尋不就可以了。後來發現這題目不是這麼簡單,複雜度真是高了去了。搜的題解也是由多種做法,我目前只看了一種,後幾種以後慢慢補上。就這一種方法我也有點不理解,STL中queue的複雜度這麼高麼,都得手寫佇列。還有為什麼要用康拓展開實現100%的雜湊,縮小了所佔記憶體?不雜湊我也覺得不是很複雜。先挖好坑,以後慢慢補。我得試試用queue和不雜湊能不能掛了,目測應該會掛。多看幾遍,希望能理解透。
#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;

struct Node
{
    int state;
    int s[9];
    int location,pre;
    char path;
}node[1000010];

bool vis[1000010];
int f[9]={1,1,2,6,24,120,720,5040,40320};
int dir[4][2]={{-1,0},{1,0},{0,-1},{0,1}};
char op[4]={'u','d','l','r'};
int head,tail;

int cantor(int s[])
{
    int i,j;
    int num,sum=0;
    for(i=0;i<9;i++)
    {
        num=0;
        for(j=0;j<i;j++)
            if(s[j]>s[i])
                num++;
        sum+=(num*f[i]);
    }
    return sum+1;
}

int bfs(Node now)
{
    int i,j;

    memset(vis,0,sizeof(vis));
    head=tail=0;

    now.state=cantor(now.s);
    vis[now.state]=1;
    node[tail++]=now;//放入隊尾,從隊尾放元素

    Node temp;
    while(head!=tail)//取出隊首元素進行搜尋,將符合條件的下一步搜尋再放入佇列中
    {
        now=node[head++];//取出當前隊首元素
        if(now.state==1)//123456789的雜湊值為1
            return head-1;

        //system("pause");
        //cout<<"HEAD:"<<head<<"  TAIL:"<<tail;

        int x=now.location/3;
        int y=now.location%3;
        for(i=0;i<4;i++)
        {
            int xx=x+dir[i][0];
            int yy=y+dir[i][1];

            if(xx>=0&&xx<=2&&yy>=0&&yy<=2)
            {
                temp=now;
                temp.s[3*x+y]=temp.s[3*xx+yy];//交換位置
                temp.s[3*xx+yy]=9;
                temp.state=cantor(temp.s);
                if(!vis[temp.state])
                {
                    vis[temp.state]=1;
                    temp.location=xx*3+yy;
                    temp.path=op[i];//儲存操作
                    temp.pre=head-1;
                    node[tail++]=temp;
                }
            }
        }
    }
    return -1;
}

void Print(int i)//壓棧,輸出路徑
{
    if(i==0) return;
    Print(node[i].pre);
    cout<<node[i].path;
}

int main()
{
    int i,cnt=0;
    char ch[50];
    Node start;
    gets(ch);

    for(i=0;ch[i];i++)
    {
        if(ch[i]==' ') continue;
        if(ch[i]=='x')
        {
            start.s[cnt]=9;
            start.location=cnt++;
        }
        else
            start.s[cnt++]=ch[i]-'0';
    }
    int ans=bfs(start);
    if(ans==-1)
        cout<<"unsolvable"<<endl;
    else
    {
        Print(ans);
        cout<<endl;
    }
    return 0;
}