1. 程式人生 > >思維拓展--斐波那契問題

思維拓展--斐波那契問題

斐波那契問題

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2). 

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000). 

Output

Print the word "yes" if 3 divide evenly into F(n). 

Print the word "no" if not. 

Sample Input

0
1
2
3
4
5

Sample Output

no
no
yes
no
no
no

思路:

7 11 18 29 47 76 123 199 322 521 843 1364 2207 3571 5578...

我們發現  2,6,10..可以被3整除。遇到這樣的題,一般的思維會想著先把數列寫出來,然後進行作出判斷,但是,看他的資料量就應該想想是否是道規律題。

#include<stdio.h>
int main(){
    int n ;
    while(scanf("%d",&n)!=EOF){
        if(n%4 == 2){
        	printf("yes\n");
        }
        else{
        	printf("no\n");
        }
    }
    return 0;
}