1. 程式人生 > >hdoj 1005 Number Sequence (斐波那契數列 找迴圈節)

hdoj 1005 Number Sequence (斐波那契數列 找迴圈節)

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 158599    Accepted Submission(s): 38859


Problem Description A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output For each test case, print the value of f(n) on a single line.

Sample Input 1 1 3 1 2 10 0 0 0
Sample Output 2 5 因為對7取模,所以f(n)最多有7*7種可能結果,其中有一項一定是迴圈點,注意迴圈節不一定是從f(1) f(2) 開始的,(大神的解釋)
程式碼:
#include <iostream>
#include<cstdio>
using namespace std;
int f[10000005];//??為什麼開那麼大才行,開到50以上不可以??
int main()
{
    int a,b,n,m;
    f[1]=1;f[2]=1;
    while(scanf("%d%d%d",&a,&b,&n)&&(a||b||n))
    {

        m=0;
        int i,j;
        for(i=3;i<=n;i++)//找迴圈節,但是迴圈點不一定從f[1] f[2]開始
        {

            f[i]=(a*f[i-1]+b*f[i-2])%7;
            for(j=2;j<i;j++)
            {
                if(f[i-1]==f[j-1]&&f[i]==f[j])
                {
                    m=i-j;
                    break;
                }
            }
            if(m>0)
                break;
        }
        if(m>0)
        {
            f[n]=f[(n-j)%m+j];
        }
        printf("%d\n",f[n]);
    }
    return 0;
}