1. 程式人生 > >杭電ACM 1071題

杭電ACM 1071題

Problem DescriptionIgnatius bought a land last week, but he didn't know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture, can you tell Ignatius the area of the land?
Note: The point P1 in the picture is the vertex of the parabola.

InputThe input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).OutputFor each test case, you should output the area of the land, the result should be rounded to 2 decimal places.Sample Input2 5.000000 5.000000 0.000000 0.000000 10.000000 0.000000 10.000000 10.000000 1.000000 1.000000 14.000000 8.222222Sample Output33.33 40.69

我的答案:

#include<stdio.h>    //y=a*x*x+b*x+c y=k*x+m
double fax(double x1,double x2,double x3,double y1,double y2,double y3);
void main()    
{
    int n;
    scanf("%d",&n);
    double d1,d2,d3,h1,h2,h3;
    double area;
    double x1,x2,x3,y1,y2,y3;
    for(int i=0;i<n;i++)
    {
        scanf("%lf %lf",&d1,&h1);
        scanf("%lf %lf",&d2,&h2);
        scanf("%lf %lf",&d3,&h3);
        x1=d1;x2=d2;x3=d3;
        y1=h1;y2=h2;y3=h3;
        double ar=fax(x1,x2,x3,y1,y2,y3);    
        area=ar;
        printf("%.2lf\n",area);
    }
}
double fax(double x1,double x2,double x3,double y1,double y2,double y3)
{
    double a,b,c,m,k;
    k=(y3-y2)/(x3-x2);
    m=(x3*y2-x2*y3)/(x3-x2);
    a=((x2-x3)*(y1-y2)-(x1-x2)*(y2-y3))/((x1*x1-x2*x2)*(x2-x3)-(x2*x2-x3*x3)*(x1-x2));
    b=((x2*x2-x3*x3)*(y1-y2)-(x1*x1-x2*x2)*(y2-y3))/((x1-x2)*(x2*x2-x3*x3)-(x2-x3)*(x1*x1-x2*x2));
    c=((x1*x1*y2-x2*x2*y1)+b*x1*x2*(x2-x1))/(x1*x1-x2*x2);    
    double ar;
    ar=(2*a*x3*x3*x3+3*(b-k)*x3*x3+6*(c-m)*x3-(2*a*x2*x2*x2+3*(b-k)*x2*x2+6*(c-m)*x2))/6;
    return ar;
}

我按照純數學方法做此題,設三點座標,設兩方程表示式,運用公式、聯立等,用三點座標來表示所設表示式中的未知量,

在運用函式重複即可。巧妙之處在於將給出幾組資料的‘幾’這個未知量用for迴圈轉化。

數學公式嘛,可以現推,不熟練的話也就花半個小時左右的時間(托腮)(托腮)