1. 程式人生 > >1852 Ants(水+思維)

1852 Ants(水+思維)

Ants
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 17451 Accepted: 7436

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time. 

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207

題目大意:一群螞蟻在一根繩子上走,走到邊緣會掉下去,兩隻螞蟻相遇會各自往相反方向走,輸入繩子長度,和n個螞蟻在繩子上的座標,輸出螞蟻到達邊界的最長時間和最短時間。

思路題,因為螞蟻速度都相等,不需要對螞蟻進行區分,所以可以看作兩個螞蟻相遇後不往相反方向走,而是徑直往前走,這樣只需要一變迴圈比較每個螞蟻的最大值最小值即可。思路比較難想。

附上AC程式碼:

#include<bits/stdc++.h>

using namespace std;
const int maxn=1000000+5;
int cnt[maxn];
int T,l,n;
int mind,maxd;

int main()
{
    cin>>T;
    while(T--)
    {
        cin>>l>>n;
        for(int i=0;i<n;i++)
            cin>>cnt[i];
        mind=maxd=0;
        for(int i=0;i<n;i++)
        {
            mind=max(mind,min(cnt[i],l-cnt[i]));
            maxd=max(maxd,max(cnt[i],l-cnt[i]));
        }
        cout<<mind<<' '<<maxd<<endl;
    }
    return 0;
}