1. 程式人生 > >HDU 4763 Theme Section(kmp)

HDU 4763 Theme Section(kmp)

Time Limit:1000MS Memory Limit:32768KB

Description
It’s time for music! A lot of popular musicians are invited to join us in the music festival. Each of them will play one of their representative songs. To make the programs more interesting and challenging, the hosts are going to add some constraints to the rhythm of the songs, i.e., each song is required to have a ‘theme section’. The theme section shall be played at the beginning, the middle, and the end of each song. More specifically, given a theme section E, the song will be in the format of ‘EAEBE’, where section A and section B could have arbitrary number of notes. Note that there are 26 types of notes, denoted by lower case letters ‘a’ - ‘z’.

To get well prepared for the festival, the hosts want to know the maximum possible length of the theme section of each song. Can you help us?

Input
The integer N in the first line denotes the total number of songs in the festival. Each of the following N lines consists of one string, indicating the notes of the i-th (1 <= i <= N) song. The length of the string will not exceed 10^6.

Output
There will be N lines in the output, where the i-th line denotes the maximum possible length of the theme section of the i-th song.

Sample Input
5
xy
abc
aaa
aaaaba
aaxoaaaaa

Sample Output
0
0
1
1
2

題意: 給你一個字串,找到一個在原字串的前,中,後都有出現的最長子串。

思路: 很明顯是kmp中的next陣列的一個應用,先對原字串求一遍next陣列,然後得到最後一個字母和字首匹配的最長的長度,但是,這個長度不能超過原字串的三分之一,所以這個最長的長度ans = min( next[len] , len/3 ),然後再到中間找到一個在ans範圍內的最長的一個長度,而中間的這個範圍就是ans*2~len-ans,如果從 f [ ans ] 就開始找的話,可能會出現和字首重合的情況,所以要從ans*2開始找起。

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<math.h>
#include<algorithm>
#include<vector>
#include<string>
#include<queue>
#include<map>
#include<stack>
#include<set>
#define ll long long
#define maxn 1000010
const int mod=1e4+7;
using namespace std;
char s[maxn];
int f[maxn];
int n;
void getnext(char *a)
{
    memset(f,0,sizeof(f));
    int len=strlen(a);
    int i=0;
    int j=-1;
    f[0]=-1;
    while(i<len)
    {
        if(j==-1||a[i]==a[j])
        {
            i++;
            j++;
            f[i]=j;
        }
        else  j=f[j];
    }
}
int main()
{
    scanf("%d",&n);
    while(n--)
    {
        scanf("%s",s);
        int len=strlen(s);

        getnext(s);

        int ans=min(f[len],len/3);

        int cnt=0;
        for(int i=ans*2-1;i<=len-ans;i++)  cnt=cnt>f[i]?cnt:f[i];  //注意範圍,範圍沒找對還WA了一發

        ans=min(ans,cnt);

        printf("%d\n",ans);
    }

    return 0;
}