1. 程式人生 > >UVALive5520 UVA305 POJ1012 HDU1443 Joseph【數學計算+打表+水題】

UVALive5520 UVA305 POJ1012 HDU1443 Joseph【數學計算+打表+水題】

Time Limit:1000MS Memory Limit:10000K
Total Submissions:54650 Accepted:20912

Description

The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.

Input

The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.

Output

The output file will consist of separate lines containing m corresponding to k in the input file.

Sample Input

3
4
0

Sample Output

5
30

Source


問題簡述:(略)

問題分析(略)

程式說明:佔個位置,以後說明。

題記:(略)

參考連結:(略)

AC的C++語言程式如下:

/* UVALive5520 UVA305 POJ1012 HDU1443 Joseph */

#include <iostream>

using namespace std;

const int N = 14;
int Joseph[N];

bool f(int k, int m)
{
    int n, s;
    n = 2 * k;
    s = 0;
    for(int i=0; i<k; i++) {
        s = (s + m - 1) % (n - i);
        if(s < k)
            return false;
    }
    return true;
}

void maketable(int k)
{
    int j;
    for(int i=1; i<=k; i++) {
        j = i + 1;
        for(;;) {
            if(f(i, j)) {           // t(k+1)
                Joseph[i] = j;
                break;
            }
            else if(f(i, j + 1)) {  // t(k+1)+1
                Joseph[i] = j + 1;
                break;
            }
            j += i + 1;
        }
    }
}

int main()
{
    maketable(N);

    int k;
    while(cin >> k && k) {
        cout << Joseph[k] << endl;
    }

    return 0;
}