Cow Bowling(動態規劃)
阿新 • • 發佈:2019-01-30
Cow Bowling
Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow's score is the sum of the numbers of the cows visited along the way. The cow with the highest
score wins that frame.
Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.
Line 1: A single integer, N
Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.
The highest score is achievable by traversing the cows as shown above.
Time Limit: 1000MS | Memory Limit: 65536K |
Total Submissions: 19855 | Accepted: 13164 |
Description
The cows don't use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this:7 3 8 8 1 0 2 7 4 4 4 5 2 6 5
Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.
Input
Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.
Output
Line 1: The largest sum achievable using the traversal rulesSample Input
5 7 3 8 8 1 0 2 7 4 4 4 5 2 6 5
Sample Output
30
Hint
Explanation of the sample:7 * 3 8 * 8 1 0 * 2 7 4 4 * 4 5 2 6 5
Source
題意:
求一條路徑,使從頭到尾和最大。
思路:
簡單動態規劃。
程式碼:
#include <iostream>
#include <cstring>
#include <string>
using namespace std;
int num[550][550],f[550][550];
int sum;
int main()
{
int i,j;
int n;
cin>>n;
for(i=1;i<=n;i++)
{
for(j=1;j<=i;j++)
cin>>num[i][j];
}
for(j=1;j<=n;j++)f[n][j]=num[n][j];
for(i=n-1;i>=1;i--)
{
for(j=1;j<=i;j++)
f[i][j]=num[i][j]+max(f[i+1][j],f[i+1][j+1]);
}
cout<<f[1][1]<<endl;
}