1. 程式人生 > >POJ1118,Lining Up,暴力過的,hash什麼的只能仰慕

POJ1118,Lining Up,暴力過的,hash什麼的只能仰慕

Lining Up

Description


"How am I ever going to solve this problem?" said the pilot. 
Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number? 
Your program has to be efficient! 


Input

Input consist several case,First line of the each case is an integer N ( 1 < N < 700 ),then follow N pairs of integers. Each pair of integers is separated by one blank and ended by a new-line character. The input ended by N=0.


Output

output one integer for each input case ,representing the largest number of points that all lie on one line.


Sample Input

5
1 1
2 2
3 3
9 10
10 11
0


Sample Output

3

分析:

題意是給你若干個點,求出在一條直線上最多有多少點。

看到discuss裡有什麼hash之類的,聽都沒聽說過我就不亂說了。

不過程式碼短,看著舒服= =。

code:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#define MAX 700
using namespace std;
typedef struct point
{
    int x,y;
}point;
point p[MAX+5];
int main()
{
    int n,i,j,num,tmp;
    while(scanf("%d",&n),n)
    {
        num=0;
        for(i=0;i<n;i++)
            scanf("%d %d",&p[i].x,&p[i].y);
        for(i=0;i<n;i++)
            for(j=i+1;j<n;j++)
            {
                tmp=0;
                for(int k=j+1;k<n;k++)                       //直接從j+1開始
                if((p[i].x-p[k].x)*(p[j].y-p[k].y)==(p[j].x-p[k].x)*(p[i].y-p[k].y))
                    tmp++;
                if(tmp>num) num=tmp;
            }
        num+=2;
        printf("%d\n",num);
    }
    return 0;
}