1. 程式人生 > >poj 1852 Ants 發現問題,解決問題

poj 1852 Ants 發現問題,解決問題

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 17694 Accepted: 7520

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time. 

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8

38 207

/*
Ants( POJ No.1852)
n 只螞蟻以每秒 1cm 的速度在長為 Lcm 的竿子上爬行。當螞蟻爬到竿子的端點時就會掉落。
由於竿子太細,兩隻螞蟻相遇時,它們不能交錯通過,只能各自反向爬回去。對於每隻螞蟻,
我們知道它距離竿子左端的距離 xi,但不知道它當前的朝向。請計算所有螞蟻落下竿子所需
的最短時間和最長時間。 
限制條件
1 ≤ L ≤ 1e+6
1 ≤ n ≤ 1e+6
0 ≤ xi ≤ L
*/
//注意是所有螞蟻落下竿子所需的最短時間和最長時間,把題目理解錯容易gg  
#include<cstdio>
#include<iostream>
using namespace std;
const int maxn=1e+6+10;
int main(){
	int T,L,n,x;
	scanf("%d",&T);
	while(T--){
		int mi=0,mx=0;
		scanf("%d%d",&L,&n);
		for(int i=0;i<n;i++)
		{
			scanf("%d",&x);
			mi=max(mi,min(x,L-x));
			mx=max(mx,max(x,L-x));
		}
		printf("%d %d\n",mi,mx);
	}
	return 0;
}