2016SDAU課程練習一1005 Problem F
阿新 • • 發佈:2019-02-03
Problem F
"Thanks to the best age, I can buy many things!" Now Dong MW has a book to buy, it costs P Jiao. He wonders how many banknotes at least,and how many banknotes at most he can use to buy this nice book. Dong MW is a bit strange, he doesn't like to get the change, that is, he will give the bookseller exactly P Jiao.
Input T(T<=100) in the first line, indicating the case number. T lines with 6 integers each: P a1 a5 a10 a50 a100 ai means number of i-Jiao banknotes. All integers are smaller than 1000000.
Output Two integers A,B for each case, A is the fewest number of banknotes to buy the book exactly, and B is the largest number to buy exactly.If Dong MW can't buy the book with no change, output "-1 -1".
Sample Input 3 33 6 6 6 6 6 10 10 10 10 10 10 11 0 1 20 20 20
Sample Output 6 9 1 10 -1 -1 又是數硬幣,要求得出最大和最小硬幣數,很相似之前做的第二套練習題的數硬幣的題,只不過這道題要求得出最大硬幣數,而這也正是本題的最大難點。 關鍵是轉換,把最多轉化為錢最多硬幣最少,這一步好難好難的。。。。 #include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<set>
#include<algorithm>
using namespace std;
int min(int r,int b[],int c[],int a[]){
for(int i=5;i>0;i--){
if(r/b[i]<a[i]){
c[i]=r/b[i];
r=r-b[i]*c[i];
}
else{
c[i]=a[i];
r=r-c[i]*b[i];
}
}
return r;
}
int max(int k,int e[],int b[],int a[]){
for(int i=5;i>0;i--){
if(k/b[i]<a[i]){
e[i]=k/b[i];
k-=b[i]*e[i];
}
else{
e[i]=a[i];
k=k-e[i]*b[i];
}
}
return k;
}
int main(){
int a[7],c[7],e[7],b[6]={0,1,5,10,50,100};
int p,r,sum,k;
int t;
cin>>t;
while(t--){
sum=0;
cin>>p;
r=p;
for(int i=1;i<=5;i++){
cin>>a[i];
sum+=b[i]*a[i];
r=min(r,b,c,a);
if(r!=0){
cout<<"-1 -1"<<endl;
continue;
}
else{
k=sum-p;
k=max(k,e,b,a);
if(k==0){
printf("%d %d\n",c[1]+c[2]+c[3]+c[4]+c[5],(a[1]+a[2]+a[3]+a[4]+a[5]-(e[1]+e[2]+e[3]+e[4]+e[5])));
}
}
}
}
return 0;
}
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 100 Accepted Submission(s) : 36
Problem Description "Yakexi, this is the best age!" Dong MW works hard and get high pay, he has many 1 Jiao and 5 Jiao banknotes(紙幣), some day he went to a bank and changes part of his money into 1 Yuan, 5 Yuan, 10 Yuan.(1 Yuan = 10 Jiao)"Thanks to the best age, I can buy many things!" Now Dong MW has a book to buy, it costs P Jiao. He wonders how many banknotes at least,and how many banknotes at most he can use to buy this nice book. Dong MW is a bit strange, he doesn't like to get the change, that is, he will give the bookseller exactly P Jiao.
Input T(T<=100) in the first line, indicating the case number. T lines with 6 integers each: P a1 a5 a10 a50 a100 ai means number of i-Jiao banknotes. All integers are smaller than 1000000.
Output Two integers A,B for each case, A is the fewest number of banknotes to buy the book exactly, and B is the largest number to buy exactly.If Dong MW can't buy the book with no change, output "-1 -1".
Sample Input 3 33 6 6 6 6 6 10 10 10 10 10 10 11 0 1 20 20 20
Sample Output 6 9 1 10 -1 -1 又是數硬幣,要求得出最大和最小硬幣數,很相似之前做的第二套練習題的數硬幣的題,只不過這道題要求得出最大硬幣數,而這也正是本題的最大難點。 關鍵是轉換,把最多轉化為錢最多硬幣最少,這一步好難好難的。。。。 #include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<set>
#include<algorithm>
using namespace std;
int min(int r,int b[],int c[],int a[]){
for(int i=5;i>0;i--){
if(r/b[i]<a[i]){
c[i]=r/b[i];
r=r-b[i]*c[i];
}
else{
c[i]=a[i];
r=r-c[i]*b[i];
}
}
return r;
}
int max(int k,int e[],int b[],int a[]){
for(int i=5;i>0;i--){
if(k/b[i]<a[i]){
e[i]=k/b[i];
k-=b[i]*e[i];
}
else{
e[i]=a[i];
k=k-e[i]*b[i];
}
}
return k;
}
int main(){
int a[7],c[7],e[7],b[6]={0,1,5,10,50,100};
int p,r,sum,k;
int t;
cin>>t;
while(t--){
sum=0;
cin>>p;
r=p;
for(int i=1;i<=5;i++){
cin>>a[i];
sum+=b[i]*a[i];
r=min(r,b,c,a);
if(r!=0){
cout<<"-1 -1"<<endl;
continue;
}
else{
k=sum-p;
k=max(k,e,b,a);
if(k==0){
printf("%d %d\n",c[1]+c[2]+c[3]+c[4]+c[5],(a[1]+a[2]+a[3]+a[4]+a[5]-(e[1]+e[2]+e[3]+e[4]+e[5])));
}
}
}
}
return 0;
}