1. 程式人生 > >Halloween Costumes LightOJ

Halloween Costumes LightOJ

Gappu has a very busy weekend ahead of him. Because, next weekend is Halloween, and he is planning to attend as many parties as he can. Since it's Halloween, these parties are all costume parties, Gappu always selects his costumes in such a way that it blends with his friends, that is, when he is attending the party, arranged by his comic-book-fan friends, he will go with the costume of Superman, but when the party is arranged contest-buddies, he would go with the costume of 'Chinese Postman'.

Since he is going to attend a number of parties on the Halloween night, and wear costumes accordingly, he will be changing his costumes a number of times. So, to make things a little easier, he may put on costumes one over another (that is he may wear the uniform for the postman, over the superman costume). Before each party he can take off some of the costumes, or wear a new one. That is, if he is wearing the Postman uniform over the Superman costume, and wants to go to a party in Superman costume, he can take off the Postman uniform, or he can wear a new Superman uniform. But, keep in mind that, Gappu doesn't like to wear dresses without cleaning them first, so, after taking off the Postman uniform, he cannot use that again in the Halloween night, if he needs the Postman costume again, he will have to use a new one. He can take off any number of costumes, and if he takes off k

 of the costumes, that will be the last k ones (e.g. if he wears costume A before costume B, to take off A, first he has to remove B).

Given the parties and the costumes, find the minimum number of costumes Gappu will need in the Halloween night.

Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case starts with a line containing an integer N (1 ≤ N ≤ 100) denoting the number of parties. Next line contains N integers, where the ith integer ci (1 ≤ ci ≤ 100) denotes the costume he will be wearing in party i. He will attend party 1 first, then party 2, and so on.

Output

For each case, print the case number and the minimum number of required costumes.

Sample Input

2

4

1 2 1 2

7

1 2 1 1 3 2 1

Sample Output

Case 1: 3

Case 2: 4

題意

有個人要去參加一些不同的聚會,不同聚會要穿不同衣服,給你參加聚會的順序,問最小需要準備多少衣服

這個人可以在裝著衣服時再穿一件,脫掉後再去參見之前型別的聚會,但脫掉之後不能再穿,再穿只能記一件新衣服

思路

區間DP,在碰到有個之前參見過得一個聚會時,他可以選擇脫到之前那件,也可以選擇穿一件新的,選擇會對後面有影響。

我們可以選擇逆推,先假設他穿了一件新衣服,在判斷如果脫會不會更優。

#include <algorithm>
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <cstring>
#include <queue>
using namespace std;
int a[120],n;
int dp[120][120];
int main()
{
    int t;
    scanf("%d",&t);
    int ca = 1;
    while(t--)
    {
        scanf("%d",&n);
        for(int i = 1;i<=n ;i++) scanf("%d",&a[i]);
        memset(dp,0,sizeof(dp));
        for(int i = n;i>=1;i--)
        {
            for(int j  = i;j<=n;j++)
            {
                dp[i][j] = dp[i+1][j] + 1;
                for(int k = i+1;k<=j;k++)
                {
                    if(a[i] == a[k])
                    {
                        dp[i][j] = min(dp[i][j],dp[i+1][k]+dp[k+1][j]);
                    }
                }
            }
        }
        printf("Case %d: %d\n",ca++,dp[1][n]);
    }
    return 0;
}