1. 程式人生 > >A Bug's Life(HDU-1829)

A Bug's Life(HDU-1829)

Problem Description

Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 

Problem 

Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4 

Sample Output

Scenario #1:

Suspicious bugs found!


Scenario #2:
No suspicious bugs found!

———————————————————————————————————————————————————————

題意:同性別的合併在一個集合中,然後每次輸入看兩個值看是否在同一個集合中,裸的並查集應用

思路:利用一個數組來標記性別關係,然後把性別相同的合併到一個集合,如果發現在同一個集合便返回。

Source Program

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<string>
#include<cstdlib>
#include<queue>
#define INF 0x3f3f3f3f
#define N 2001
#define MOD 2520
#define E 1e-12
using namespace std;
int father[N];
int a[N];
int Find(int k)
{
    if(father[k]==k)
        return k;
    father[k]=Find(father[k]);
    return father[k];
}
void Union(int x,int y)
{
    x=Find(x);
    y=Find(y);
    if(x==y)
        return ;
    father[x]=y;
}
int main()
{
    int t;

    scanf("%d",&t);
    for(int l=1;l<=t;l++)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
            father[i]=i;

        memset(a,0,sizeof(a));
        bool flag=false;
        while(m--)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            if(flag)
                continue;
            if(Find(x)==Find(y))
            {
                flag=true;
                continue;
            }


            if(a[x]==0)
                a[x]=y;
            else
                Union(a[x],y);

            if(a[y]==0)
                a[y]=x;
            else
                Union(a[y],x);
        }

        printf("Scenario #%d:\n",l);
        if(flag)
            printf("Suspicious bugs found!\n\n");
        else
            printf("No suspicious bugs found!\n\n");
    }
    return 0;
}