1. 程式人生 > >HDOJ-2008-數值統計

HDOJ-2008-數值統計

數值統計

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 70564    Accepted Submission(s): 35452


Problem Description 統計給定的n個數中,負數、零和正數的個數。
Input 輸入資料有多組,每組佔一行,每行的第一個數是整數n(n<100),表示需要統計的數值的個數,然後是n個實數;如果n=0,則表示輸入結束,該行不做處理。
Output 對於每組輸入資料,輸出一行a,b和c,分別表示給定的資料中負數、零和正數的個數。
Sample Input 6 0 1 2 3 -1 0 5 1 2 3 4 0.5 0
Sample Output 1 2 3 0 0 5


水題,直接貼了

#include<stdio.h>
int main()
{
	int n,i,count,count1,count2;
	double x;
	while(scanf("%d",&n)!=EOF&&n!=0)
	{
		for(i=0,count=0,count1=0,count2=0;i<n;i++)
		{
			scanf("%lf",&x);
			if(x>0)
			count1++;
			if(x<0)
			count2++;
			if(x==0)
			count++;
		}
		printf("%d %d %d\n",count2,count,count1);
	}
	return 0;
}