1. 程式人生 > >ACM刷題之POJ————River Hopscotch

ACM刷題之POJ————River Hopscotch

River Hopscotch
Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 17988Accepted: 7516

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L

 units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to 

rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: LN, and M 
Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

一道二分的題目

一般題目讓你求什麼,就二分什麼,這裡求距離,就二分距離。

這裡的輸入資料是無序的,記得排序。

統計節點的距離小於二分值的個數,然後比較就好了。

注意一點,刪除後,那個節點前後距離都會改變,不能單單計算前面減後面的距離來計數。

這裡給兩個樣例:

10 0 0 

0

10 1 1

6

10

下面是ac程式碼

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<algorithm>
#include<map>
#include<set>
#include<queue>
#include<string>
#include<iostream>
using namespace std;
#define MID(x,y) ((x+y)>>1)
#define CLR(arr,val) memset(arr,val,sizeof(arr))
#define FAST_IO ios::sync_with_stdio(false);cin.tie(0);
const double PI = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int N=2e5+7;

int i, j, le, n , m; 
int a[N];

bool check(int mi) {
	int cnt = 0, before = 0;
	for (i = 1 ; i <= n; i ++) {
		if (a[i] - a[before] <= mi) {
			++cnt;
		} else {
			before = i;
		}
	}
	if (cnt > m) {
		return true;
	} else return false;
}

int main()
{
	//freopen("f:/input.txt", "r", stdin);
	while(cin>>le>>n>>m) {
		int maxn = -INF;
		a[0] = 0;
		for (i = 1; i <= n; i ++) {
			cin>>a[i];
			if (a[i] > maxn) maxn = a[i];
		}
		a[++n] = le; 
		sort(a, a + n);
		int l = 0, r = le * 2, mid;
		while (l < r) {
			mid = MID(l, r);
			if (check(mid)) {
				r = mid;
			} else {
				l = mid + 1;
			}
		}
//		if (l == le) --l;
		cout<<l<<endl;
	}
}