1. 程式人生 > >POJ 1862 Stripies(優先佇列)

POJ 1862 Stripies(優先佇列)

Stripies

Time Limit: 1000MS

Memory Limit: 30000K

Total Submissions: 19699

Accepted: 8800

Description

Our chemical biologists have invented a new very useful form of life called stripies (in fact, they were first called in Russian - polosatiki, but the scientists had to invent an English name to apply for an international patent). The stripies are transparent amorphous amebiform creatures that live in flat colonies in a jelly-like nutrient medium. Most of the time the stripies are moving. When two of them collide a new stripie appears instead of them. Long observations made by our scientists enabled them to establish that the weight of the new stripie isn't equal to the sum of weights of two disappeared stripies that collided; nevertheless, they soon learned that when two stripies of weights m1 and m2 collide the weight of resulting stripie equals to 2*sqrt(m1*m2). Our chemical biologists are very anxious to know to what limits can decrease the total weight of a given colony of stripies. 
You are to write a program that will help them to answer this question. You may assume that 3 or more stipies never collide together. 

Input

The first line of the input contains one integer N (1 <= N <= 100) - the number of stripies in a colony. Each of next N lines contains one integer ranging from 1 to 10000 - the weight of the corresponding stripie.

Output

The output must contain one line with the minimal possible total weight of colony with the accuracy of three decimal digits after the point.

Sample Input

3
72
30
50

Sample Output

120.000

Source

------------------------------------------------------------

思路

【題意】

有N個動物,每個有一個重量m, 重量為m1,m2的兩個動物合成重量為2*sqrt(m1*m2)的動物,問所有N個動物全部合成之後的最小重量是多少

【思路】

最大優先佇列,總是最大的兩兩合成合成出來的總重量最小。

------------------------------------------------------------

程式碼

// 最大優先佇列

#include<cstdio>
#include<queue>
#include<cmath>
using namespace std;

const int NMAX = 105;

int main()
{
#ifndef ONLINE_JUDGE
	freopen("1862.txt","r",stdin);
#endif
	int n,i;
	double a,b;
	scanf("%d", &n);
	priority_queue<double> q;
	for (i=0; i<n; i++)
	{
		scanf("%lf", &a);
		q.push(a);
	}
	while (q.size()>1)
	{
		a = q.top();
		q.pop();
		b = q.top();
		q.pop();
		a = 2*sqrt(a*b);
		q.push(a);
	}
	printf("%.3lf",q.top());
	return 0;
}