1. 程式人生 > >Yukari's Birthday(精度處理) (二分)

Yukari's Birthday(精度處理) (二分)

Yukari's Birthday

Time Limit: 12000/6000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2910    Accepted Submission(s): 610


Problem Description Today is Yukari's n-th birthday. Ran and Chen hold a celebration party for her. Now comes the most important part, birthday cake! But it's a big challenge for them to place n candles on the top of the cake. As Yukari has lived for such a long long time, though she herself insists that she is a 17-year-old girl.
To make the birthday cake look more beautiful, Ran and Chen decide to place them like r ≥ 1 concentric circles. They place ki
candles equidistantly on the i-th circle, where k ≥ 2, 1 ≤ i ≤ r. And it's optional to place at most one candle at the center of the cake. In case that there are a lot of different pairs of r and k satisfying these restrictions, they want to minimize r × k. If there is still a tie, minimize r.

Input There are about 10,000 test cases. Process to the end of file.
Each test consists of only an integer 18 ≤ n ≤ 1012
.

Output For each test case, output r and k.
Sample Input 18 111 1111
Sample Output 1 17 2 10 3 10
 # include<iostream>
 # include<cstdio>
 # include<cstring>
 # include<algorithm>
 # include<cmath>
 # define  lh   __int64
 using namespace std;


 lh powll(lh x,int y)
 {
     lh res=1;
     for(int i=0;i<y;i++)
     {
         res*=x;
     }
     return res;
 }

 int main()
 {
     lh n;
    lh r,k;
     while(~scanf("%I64d",&n))
     {
         r=1;
         k=n-1;
        lh ll,rr,mm;
        for(int i=2;i<=45;i++)
        {
            ll=2;
            rr=(lh)pow(n,1.0/i);               //規定上界
            while(ll<=rr)
            {
                 mm=(lh)(ll+rr)/2;
                 lh ans=(mm-powll(mm,i+1))/(1-mm);
                 if(ans==n||ans==n-1)
                 {
                     if(i*mm<r*k)
                     {
                         r=i;
                         k=mm;
                     }
                     break;
                 }
                 else if(ans>n)
                      rr=mm-1;
                 else
                      ll=mm+1;

            }
        }
         printf("%I64d %I64d\n",r,k);
    }
     return 0;
 }