1. 程式人生 > >A - Packets 貪心

A - Packets 貪心

ram 數量 vid indicate while live esc lib ++

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null‘‘ line of the input file.

Sample Input

0 0 4 0 0 1 
7 5 1 0 0 0 
0 0 0 0 0 0 

Sample Output

2 
1 


題目大意
就是給你六個數字,從前往後依次代表,i*i類型的箱子,不考慮高度,問你給你最少多少個6*6的箱子
首先意識到,4,5,6單獨占一個箱子,3*3的四個占一個箱子,先根據3,4,5,6求出一個大概的數量
之後2就填充3,4占用的箱子空下來的空間,1就占用其他空間。


#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <algorithm>
#include <iostream>
using namespace std;
int dir[4]={0,5,3,1};
int main()
{
    int a[10];
    while(1)
    {
        int sum=0,ans=0;
        for(int i=1;i<=6;i++)
        {
            scanf("%d",&a[i]);
            sum+=a[i];
        }
        if(sum==0) break;
        ans=(a[3]+3)/4+a[4]+a[5]+a[6];
        int cnt_2=a[4]*5+dir[a[3]%4];
        if(a[2]>cnt_2)
        {
            ans+=(8+a[2]-cnt_2)/9;
        }
        int cnt_1=ans*36-a[3]*9-a[4]*16-a[5]*25-a[6]*36-a[2]*4;
        if(a[1]>cnt_1)
        {
            ans+=(35+a[1]-cnt_1)/36;
        }
        printf("%d\n",ans);
    }
    return 0;
}

  



A - Packets 貪心