1. 程式人生 > >POJ 1258 Agri-Net 最小生成樹

POJ 1258 Agri-Net 最小生成樹

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 
Input The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem. Output For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms. Sample Input
4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0
Sample Output
28

解題思路:

給你一個對稱矩陣,表示i,j的距離,讓你求最小生成樹,模板一套就行了,kruskal演算法

#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
const int maxn = 100005 ;
const int INF = 0x3f3f3f3f ;
int pa[maxn] ;
int findset(int x){return pa[x]!=x?pa[x]=findset(pa[x]):x ;}
struct Edge{
    int u,v,d ;
    Edge(int u,int v,int d):u(u),v(v),d(d){}
    bool operator < (const Edge& p)const {
        return d<p.d ;
    }
};
vector<Edge>e;
int n,m;
int solve(){
    sort(e.begin(),e.end()) ;
    int ans = INF ;
    int ret = 0 ;
    for(int i=1;i<=n;i++){
        pa[i]=i ;
    }
    int cnt = 0 ;
    for(int i=0;i<m;i++){
        int u=findset(e[i].u) ;
        int v=findset(e[i].v) ;
        if(u!=v){
            pa[v]=u ;
            cnt++ ;
            ret+= e[i].d;
            if(cnt==n-1)break ;
        }
    }
    return ret ;
}
int mapp[105][105] ;
int main(){
    while(~scanf("%d",&n)){
        e.clear();
        m=n*(n-1)/2 ;
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++){
                int a ;
                scanf("%d",&a);
                if(i>j){
                    e.push_back(Edge(i,j,a));
                }
            }
        }
        printf("%d\n",solve());
    }
    return 0;
}