1. 程式人生 > >acm java 救基友記2

acm java 救基友記2

Problem Description

   屌絲WP的好基友CZ又被妖鬼給抓走了(CZ啊,CZ….怎麼說你好呢.吃著鍋裡想著碗裡),為了求出CZ,他只好去求高富帥RQ, RQWP出了到題目說只要你能解決這道題目,他就答應幫屌絲WP去解救好基友CZ。題目描述如下:
  給你一個字串s,長度小於1000,讓你找出該字串所包含的所有子串"cRazY" 或者"CraZy",並將找出的子串的大寫字母變成小寫字母,小寫字母變成大寫字母,然後輸出該字串。
  “好基友,一被子”你作為WP的好基友,能幫他解決這個問題嗎?

Input

 1行是一個整數T,表示測試資料的個數(1<=T<=10)。接下來有T組測試資料。

每組測試資料包括包括一個字串s

Output

 輸出T行,表示轉換後的字串 

Sample Input

2
abjbjhcRazYdcRazYCraZy
bbbnnnbbn

Sample Output

abjbjhCrAZydCrAZycRAzY
bbbnnnbbn

import java.util.Scanner;  
  
public class Main {  
    public static void main(String[] args) {  
        Scanner reader = new Scanner(System.in);  
        int n = reader.nextInt();
        String str1 = "cRazY";
        String str2 = "CraZy";
        String newstr1 = "CrAZy";
        String newstr2 = "cRAzY";
        for(int i=0; i<n; i++) {
        	String str = reader.next();
        	System.out.println(replace(str, str1, newstr1, str2, newstr2));
        }
    }  
    public static String replace(String str, String str1, String newstr1, String str2, String newstr2) {
    	str = str.replace(str1, newstr1);
    	str = str.replace(str2, newstr2);
    	return str;
    }
}