1. 程式人生 > >PAT甲級1054

PAT甲級1054

The Dominant Color

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictlydominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800x600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (<=800) and N (<=600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0, 2^24^). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:

24

程式原始碼:

#include<iostream>
#include<map>
using namespace std;
int main()
{
    std::ios::sync_with_stdio(false);
    int n,m;
    cin>>m>>n;
    map<int,int> ran;
    int half=m*n/2;
    for(int i=0;i<n;i++)
        for(int j=0;j<m;j++)
    {
        int col;
        cin>>col;
        ran[col]++;
        if(ran[col]>half)
        {
            cout<<col;
            return 0;
        }
    }
    return 0;
}

第一次提交時沒有加入下面這行程式碼

std::ios::sync_with_stdio(false);
導致超時,後經查詢得知cin慢是有原因的,其實預設的時候,cin與stdin總是保持同步的,也就是說這兩種方法可以混用,而不必擔心檔案指標混亂,同時cout和stdout也一樣,兩者混用不會輸出順序錯亂。正因為這個相容性的特性,導致cin有許多額外的開銷。只要使用上面這行語句就可以取消cin於stdin的同步了。