1. 程式人生 > >ZOJ1159 UVA755 UVALive5420 487-3279【查表】

ZOJ1159 UVA755 UVALive5420 487-3279【查表】

Time Limit:10 Seconds     Memory Limit:32768 KB
Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their ``three tens'' number 3-10-10-10.

The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows:

A, B, and C map to 2

D, E, and F map to 3

G, H, and I map to 4

J, K, and L map to 5

M, N, and O map to 6

P, R, and S map to 7

T, U, and V map to 8

W, X, and Y map to 9

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010.

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.)

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number.


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.


Input

The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters.

Output

Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line:

No duplicates.


Sample Input

1

12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279


Sample Output

310-1010 2
487-3279 4
888-4567 3


問題簡述:為了好記電話號碼,將字母對映為數字,人們就可以記憶字母了。給定若干的電話號碼,如果沒有重複就不輸出,如果有重複則輸出電話號碼及重複次數。如果沒有一個電話號碼是重複的,則輸出“No duplicates”。

問題分析:這個問題的關鍵是用什麼樣的資料結構儲存有關的資訊。需要找到最簡潔的字母轉換數字的方式,電話號碼的儲存方式。

程式說明:這個問題與參考連結的問題是同一問題,只是輸入輸出形式不同。

題記:(略)

AC的C語言程式如下:

/* ZOJ1159 UVA755 UVALive5420 487-3279 */

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <ctype.h>

using namespace std;

int convert[] =
{
    2, 2, 2,
    3, 3, 3,
    4, 4, 4,
    5, 5, 5,
    6, 6, 6,
    7, 0, 7, 7,
    8, 8, 8,
    9, 9, 9,
    0
};

const int N = 128;
char s[N];
const int N2 = 100000;
int ans[N2], acount;

int main()
{
    int t, n, num;
    bool tflag = false;

    scanf("%d", &t);
    while(t--) {
        if(tflag)
            printf("\n");
        tflag = true;

        scanf("%d", &n);
        for(int k=0; k<n; k++) {
            scanf("%s", s);

            num = 0;
            for(int i=0; s[i]; i++) {
                if(isdigit(s[i])) {
                    num *= 10;
                    num += s[i] - '0';
                } else if(isupper(s[i])) {
                    num *= 10;
                    num += convert[s[i] - 'A'];
                }
            }
            ans[k] = num;
        }

        sort(ans, ans + n);

        bool flag = true;
        int count = 1;
        for(int i=1; i<n; i++) {
            if(ans[i] == ans[i - 1])
                count++;
            else {
                if(count > 1) {
                    printf("%03d-%04d %d\n", ans[i - 1] / 10000, ans[i - 1] % 10000, count);
                    flag = false;
                }
                count = 1;
            }
        }
        if(count > 1) {
            printf("%03d-%04d %d\n", ans[n - 1] / 10000, ans[n - 1] % 10000, count);
            flag = false;
        }

        if(flag)
            printf("No duplicates.\n");
    }

    return 0;
}