POJ 1256:Anagram
Anagram
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 18393 Accepted: 7484
Description
You are to write a program that has to generate all possible words from a given set of letters.
Example: Given the word “abc”, your program should - by exploring all different combination of the three letters - output the words “abc”, “acb”, “bac”, “bca”, “cab” and “cba”.
In the word taken from the input file, some letters may appear more than once. For a given word, your program should not produce the same word more than once, and the words should be output in alphabetically ascending order.
Input
The input consists of several words. The first line contains a number giving the number of words to follow. Each following line contains one word. A word consists of uppercase or lowercase letters from A to Z. Uppercase and lowercase letters are to be considered different. The length of each word is less than 13.
Output
For each word in the input, the output should contain all different words that can be generated with the letters of the given word. The words generated from the same input word should be output in alphabetically ascending order. An upper case letter goes before the corresponding lower case letter.
Sample Input
3
aAb
abc
acba
Sample Output
Aab
Aba
aAb
abA
bAa
baA
abc
acb
bac
bca
cab
cba
aabc
aacb
abac
abca
acab
acba
baac
baca
bcaa
caab
caba
cbaa
Hint
An upper case letter goes before the corresponding lower case letter.
So the right order of letters is ‘A’<’a’<’B’<’b’<…<’Z’<’z’.
題意就是按照字典順序輸出所有字串。
正常來說,只需要一個sort,一個next_permutation就OK的題,唯一一個值得說明的就是要把A,B,C這樣的大寫字母穿插到裡面,要不然出來的順序不會是AaBbCc,而是ABCabc。所以需要自己寫一個自定義函式cmp用來比較。我這裡為了穿插進去,使用了ASCII碼+31.5,就使得每一個大寫字母剛好穿進了小寫字母中。
程式碼:
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <string>
using namespace std;
char s[5000];
bool cmp(char a,char b)
{
double front,behind;
if(a>='A'&&a<='Z')
front = (double)a+31.5;
else
front = (double)a;
if(b>='A'&& b<='Z')
behind = (double)b+31.5;
else
behind = (double)b;
return front<behind;
}
int main()
{
int count;
cin>>count;
while(count--)
{
cin>>s;
sort(s,s+strlen(s),cmp);
do
{
cout<<s<<endl;
}while(next_permutation(s,s+strlen(s),cmp));
}
return 0;
}