1. 程式人生 > >POJ 2559(第三屆河南省程式設計大賽F題(單調棧應用))

POJ 2559(第三屆河南省程式設計大賽F題(單調棧應用))

Largest Rectangle in a Histogram
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 21082 Accepted: 6787

Description

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: 

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1<=n<=100000. Then follow n integers h1,...,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1
. A zero follows the input for the last test case.

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

8
4000

題解:題目大意:有些時候學習英語也是程式設計師的必經之路,所以自己去看吧。

           我的思路:單調棧水一發就過了。 如果不知道單調棧是什麼可以去這個部落格看看:文西的部落格(其實我也是剛去學的大笑

下面是我的程式碼:

#include<cstdio>
#include<cmath>
#include<cstring>
#include<climits>
#include<string>
#include<queue>
#include<map>
#include<algorithm>
#include<iostream>
#include<stack>
#include<vector>
#define ll long long
using namespace std;

const int maxn = 100005;
int n;
ll heights[maxn];
struct node
{
    ll height;  // 高度
    int startindex; // 滿足該高度的最先出現的位置
    node(ll _height, int _index):height(_height), startindex(_index){};
};
ll getmaxarea()
{
    stack<node> s;
    s.push(node(-1, 0));
    ll height1, currentarea, maxarea = 0;
    int currentposition;
    for(int i = 0; i <= n; i++)
    {
        currentposition = i+1;
        if(i == n)
            height1 = 0;
        else
        height1 = heights[i];
        node cur(height1, currentposition);
        while(height1<s.top().height) // pop所有比當前高度大的節點
        {
            cur = s.top();
            s.pop();
            currentarea = (currentposition-cur.startindex)*cur.height;
            maxarea = max(maxarea, currentarea);
        }
        s.push(node(height1, cur.startindex)); //入棧
    }
    return maxarea;
}
int main()
{
    while(~scanf("%d", &n) && n)
    {
        for(int i = 0; i < n; i++)
        {
            scanf("%lld", heights+i);
        }
        printf("%lld\n", getmaxarea());
    }
    return 0;
}