1. 程式人生 > >PAT 甲級 1029 Median

PAT 甲級 1029 Median

strong == esp file nta san tps pre integer

https://pintia.cn/problem-sets/994805342720868352/problems/994805466364755968

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (2×10?5??) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13

代碼:

#include <bits/stdc++.h>
using namespace std;

const int maxn = 2e5 + 10;
int N, M;
int a[maxn];

int main() {
    scanf("%d", &N);
    for(int i = 1; i <= N; i ++)
        scanf("%d", &a[i]);
    a[N + 1] = INT_MAX;
    int cnt = 0;
    int temp;
    scanf("%d", &M);
    int mid = (N + M + 1) / 2;
    int i = 1;
    for(int j = 1; j <= M; j ++) {
        scanf("%d", &temp);
        while(a[i] < temp) {
            cnt ++;
            if(cnt == mid) printf("%d", a[i]);
            i ++;
        }
        cnt ++;
        if(cnt == mid) printf("%d", temp);
    }
    while(i < N) {
        cnt ++;
        if(cnt == mid) printf("%d", a[i]);
        i ++;
    }
    return 0;
}

  不能把兩個數組合並起來再排序求中位數 會內存超限 先輸入第一個數組之後 算出中位數是第幾個 然後輸入第二個數組 如果輸入當前比第一個數組的起始的大 那麽 cnt ++ 然後第一個數組向後挪一位 如果一直沒有比第一個數組大的那麽在第二個數組裏繼續計數 如果還不到 mid 那麽回第一個數組中繼續

FH

PAT 甲級 1029 Median