1. 程式人生 > >ACM-HDU水題(回憶C++語法)

ACM-HDU水題(回憶C++語法)

題目來源:

https://blog.csdn.net/liuqiyao_01/article/details/8477645

#include<iostream>
using namespace std;
#include<cstdio>
int main()
{
	int a,b;
	while(scanf("%d%d",&a,&b)!=EOF)
	{//使用EOF表示輸入不為空 
		printf("%d\n",a+b);
	}
	return 0;
}

1089 A+B for Input-Output Practice (I)

同上

1094 A+B for Input-Output Practice (VI)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 84553    Accepted Submission(s): 56325


Problem DescriptionYour task is to calculate the sum of some integers.

InputInput contains multiple test cases, and one case one line. Each case starts with an integer N, and then N integers follow in the same line.

OutputFor each test case you should output the sum of N integers in one line, and with one line of output for each line in input.

Sample Input4 1 2 3 4 5 1 2 3 4 5
#include<cstdio>
using namespace std;
int n,sum=0;
int main()
{
	for(;;)
	{
		if(scanf("%d",&n)==EOF)//有了這個之後,當讀取不到n時,自動推出
		  break;
		sum=0;
		int a;
		for(int i=1;i<=n;++i)
		{
			scanf("%d",&a);
			sum+=a;
		}
		printf("%d\n",sum);
		sum=0;
	}
	
	return 0;
}

1001 Sum Problem

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 546810    Accepted Submission(s): 138807


Problem DescriptionHey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.

InputThe input will consist of a series of integers n, one integer per line.

OutputFor each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

Sample Input1 100
Sample Output1 5050 
#include<cstdio>
using namespace std;
int n,sum=0;
int main()
{
	while(scanf("%d",&n)!=EOF)
	{
		sum=0; 
		for(int i=1;i<=n;++i)
		{
			sum+=i;
		}
		printf("%d\n\n",sum);//題目說了,有一個空行,每一行之間output SUM(n) in one line, followed by a blank line.
	}
	return 0;
}
發現題目太水了,懶得寫了