1. 程式人生 > >poj 2182 Lost Cows(線段樹經典題)

poj 2182 Lost Cows(線段樹經典題)

題目連結:http://poj.org/problem?id=2182

Lost Cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9152 Accepted: 5879

Description

N (2 <= N <= 8,000) cows have unique brands in the range 1..N. In a spectacular display of poor judgment, they visited the neighborhood 'watering hole' and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands. 

Regrettably, FJ does not have a way to sort them. Furthermore, he's not very good at observing problems. Instead of writing down each cow's brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow. 

Given this data, tell FJ the exact ordering of the cows. 

Input

* Line 1: A single integer, N 

* Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on. 

Output

* Lines 1..N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.

Sample Input

5
1
2
1
0

Sample Output

2
4
5
3
1

Source


線段樹的一道經典題目。這個題目可以轉化成從後向前依次查詢,比如當前奶牛的前面有x個號碼比它小的奶牛,那麼它就應該在剩餘的數的序列中排第x+1,當某個號碼確定時,就線上段樹中去除這個號碼。我們遍歷一下線段樹若左子樹區間內未刪除元素個數滿足當前要找的數成為第a+1個,能則遞迴左子樹,否則遞迴右子樹,直至到葉子節點,那麼葉子節點的值就是其初始編號。

#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<cstdio>
#include<vector>
#include<bitset>
#include<string>
#include<queue>
#include<stack>
#include<set>
#include<map>
#include<cstdlib>
using namespace std;
#define CLR(A) memset(A,0,sizeof(A))
const int MAX=8010;
struct Node{
    int l,r,len,v;
}tree[MAX*4];
int ans[MAX];
int f[MAX];
inline void pushup(int id){
    tree[id].len=tree[id<<1].len+tree[id<<1|1].len;
}
void build(int id,int l,int r){
    tree[id].l=l;tree[id].r=r;
    if(l==r){
        tree[id].v=l;
        tree[id].len=1;
        return;
    }
    int m=(l+r)>>1;
    build(id<<1,l,m);
    build(id<<1|1,m+1,r);
    pushup(id);
}
void query(int id,int cur,int pos){
    if(tree[id].l==tree[id].r){
        tree[id].len=0;
        ans[pos]=tree[id].v;
        return;
    }
    if(tree[id<<1].len>=cur) query(id<<1,cur,pos);
    else query(id<<1|1,cur-tree[id<<1].len,pos);
    pushup(id);
}
int main(){
    int n;
    while(~scanf("%d",&n)&&n){
        for(int i=2;i<=n;i++){
            scanf("%d",&f[i]);
            f[i]++;
        }
        build(1,1,n);
        f[1]=1;
        for(int i=n;i>=1;i--){
            query(1,f[i],i);
        }
        for(int i=1;i<=n;i++){
            printf("%d\n",ans[i]);
        }
    }
    return 0;
}