1. 程式人生 > >poj2823 單調佇列

poj2823 單調佇列

剛剛學習了單調佇列,來練習一道,等會去試試多重揹包。

Sliding Window
Time Limit: 12000MS Memory Limit: 65536K
Total Submissions: 47025 Accepted: 13585
Case Time Limit: 5000MS

Description

An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k
numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example:
The array is [1 3 -1 -3 5 3 6 7], and k is 3.
Window position Minimum value Maximum value
[1  3  -1] -3  5  3  6  7 -1 3
1 [3  -1  -3] 5  3  6  7 -3 3
1  3 [-1  -3  5] 3  6  7 -3 5
1  3  -1 [-3  5  3] 6  7
-3 5
1  3  -1  -3 [5  3  6] 7 3 6
1  3  -1  -3  5 [3  6  7] 3 7

Your task is to determine the maximum and minimum values in the sliding window at each position.

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n
integers in the second line.

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values.

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

Source

思路:單調佇列也就是在一個佇列中維護一個單調不減或單調不增的序列,每次用的時候從頭取出來。插入的時候在尾部,並在頭部刪除無效的值,具體百度。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
using namespace std;

int a[1000005];
typedef pair<int,int>P;
int top1,rear1,top2,rear2;
P que1[1000005]; //單調減
P que2[1000005]; //單調加

void insert(int x,int i)
{
  while(rear1>top1&&x<que1[rear1-1].first)
   rear1--;
  que1[rear1++]=P(x,i);
  while(rear2>top2&&x>que2[rear2-1].first)
   rear2--;
  que2[rear2++]=P(x,i);
}
int main()
{
// freopen("C:\\1.txt","r",stdin);
 int n,k;
 cin>>n>>k;
 int i;
 for(i=1;i<=n;i++)
  cin>>a[i];
 top1=rear1=0;
 top2=rear2=0;
 vector<int>res1;
 vector<int>res2;
 for(i=1;i<=k;i++)
 {
  insert(a[i],i);
 }
 for(i=k+1;i<=n;i++)
 {
  res1.push_back(que1[top1].first);
  res2.push_back(que2[top2].first);
  insert(a[i],i);
  while(que1[top1].second<i-k+1)
   top1++;
  while(que2[top2].second<i-k+1)
   top2++;
 }
 res1.push_back(que1[top1].first);
 res2.push_back(que2[top2].first);
 for(i=0;i<res1.size();i++)
 {
  printf("%d%c",res1[i],i==res1.size()-1?'\n':' ');
 }
 for(i=0;i<res2.size();i++)
 {
  printf("%d%c",res2[i],i==res2.size()-1?'\n':' ');
 }
 return 0;
}