不可摸數(杭電1999)
/*不可摸數
Problem Description
s(n)是正整數n的真因子之和,即小於n且整除n的因子和.例如s(12)=1+2+3+4+6=16.如果任何
數m,s(m)都不等於n,則稱n為不可摸數.
Input
包含多組資料,首先輸入T,表示有T組資料.每組資料1行給出n(2<=n<=1000)是整數。
Output
如果n是不可摸數,輸出yes,否則輸出no
Sample Input
3
2
5
8
Sample Output
yes
yes
no
*/
/*用打表法將 n的真因子和存到a[n]中。
注意打表的上限 確定M>=500000;
*/
#include<stdio.h>
#define M 500010
__int64 a[M];
int sum[1010];
void asd()
{
int N;
N=M/2;
int i,j;
for(i=1;i<N;i++)
for(j=2*i;j<M;j+=i)
a[j]+=i;
for(i=0;i<M;i++)
{
if(a[i]<=1000)
sum[a[i]]=1;
}
}
int main()
{
int test,i;
scanf("%d",&test);
asd();
while(test--)
{
int t;
scanf("%d",&t);
if(sum[t])
printf("no\n");
else
printf("yes\n");
}
return 0;
}