1. 程式人生 > >poj 2446 Asteroids

poj 2446 Asteroids

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X.
 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

一開始沒反應過來,這個圖的關係可以轉化一下,將x的看成1到n的結點,將y也看成1到n的結點,如果該點存在行星,那麼就將它所在的行,列結點劃上連線,表示兩點之間連通。

#include<iostream>
#include<algorithm>
#include<string.h>
#include<stdio.h>
using namespace std;
#define N 501
int vis[N],link[N],match[N][N];
int n,k;
void init()
{
    memset(link,-1,sizeof(link));
    memset(match,0,sizeof(match));
}
int dfs(int c)
{
    int i;
    for (i=1;i<=n;i++)
    {
        if (vis[i]==0&&match[c][i])
        {
            vis[i]=1;
            if (link[i]==-1||dfs(link[i]))
            {
                link[i]=c;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int i;
    while (~scanf("%d%d",&n,&k))
    {
        int num,p,q;
        init();
        for (i=1;i<=k;i++)
        {
            scanf("%d%d",&p,&q);
            match[p][q]=1;
        }
        int cnt=0;
       for (i=1;i<=n;i++)
        {
            memset(vis,0,sizeof(vis));
            if (dfs(i))
                cnt++;
        }
        printf("%d\n",cnt);
    }
    return 0;
}