1. 程式人生 > >1133 Splitting A Linked List(25 分)

1133 Splitting A Linked List(25 分)

Given a singly linked list, you are supposed to rearrange its elements so that all the negative values appear before all of the non-negatives, and all the values in [0, K] appear before all those greater than K. The order of the elements inside each class must not be changed. For example, given the list being 18→7→-4→0→5→-6→10→11→-2 and K being 10, you must output -4→-6→-2→7→0→5→10→18→11.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10​5​​) which is the total number of nodes, and a positive K (≤10​3​​). The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer in [−10​5​​,10​5​​], and Next is the position of the next node. It is guaranteed that the list is not empty.

Output Specification:

For each case, output in order (from beginning to the end of the list) the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 9 10
23333 10 27777
00000 0 99999
00100 18 12309
68237 -6 23333
33218 -4 00000
48652 -2 -1
99999 5 68237
27777 11 48652
12309 7 33218

Sample Output:

33218 -4 68237
68237 -6 48652
48652 -2 12309
12309 7 00000
00000 0 99999
99999 5 23333
23333 10 00100
00100 18 27777
27777 11 -1

思路:

給一個連結串列和K,遍歷連結串列後將<0的結點先輸出,再將0~k區間的結點輸出,最後輸出>k的結點

C++:

#include "iostream"
#include "vector"
using namespace std;
struct node
{int add,data,next;};
const int maxn=100010;
vector<node> list,neg,sma,ori;
node accord[maxn];
void linklist(int s){
	while (s!=-1)
	{
		list.push_back(accord[s]);
		s=accord[s].next;
	}
}
int main(){
	int n,k,start;
	scanf("%d %d %d",&start,&n,&k);
	for (int i=0;i<n;i++)
	{
		node temp;
		scanf("%d %d %d",&temp.add,&temp.data,&temp.next);
		accord[temp.add]=temp;
	}
	linklist(start);
	for (int i=0;i<list.size();i++)
	{
		if (list[i].data<0)
			neg.push_back(list[i]);
		if (list[i].data>=0&&list[i].data<=k)
			sma.push_back(list[i]);
		if (list[i].data>0&&list[i].data>k)
			ori.push_back(list[i]);
	}
	for(int j=0;j<sma.size();j++)neg.push_back(sma[j]);
	for(int j=0;j<ori.size();j++)neg.push_back(ori[j]);
	//重新連結
	for(int i=0;i<neg.size()-1;i++)
		neg[i].next=neg[i+1].add;
	neg[neg.size()-1].next=-1;
	for (int i=0;i<neg.size();i++){
		if (i<neg.size()-1)
		{
			printf("%05d %d %05d\n",neg[i].add,neg[i].data,neg[i].next);
		}else
		{
			printf("%05d %d %d\n",neg[i].add,neg[i].data,neg[i].next);
		}
	}
	return 0;
}