1. 程式人生 > >POJ 1056 immediately decodable (判斷是否有字首)

POJ 1056 immediately decodable (判斷是否有字首)

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.
Examples: Assume an alphabet that has symbols {A, B, C, D}
The following code is immediately decodable:
A:01 B:10 C:0010 D:0000
but this one is not:
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)

Input

    Write a program that accepts as input a series of groups of records from standard input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently). 

Output

    For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.

Sample Input

01
10
0010
0000
9
01
10
010
0000
9

Sample Output

Set 1 is immediately decodable
Set 2 is not immediately decodable

分析:

這題其實是trie樹,但是其特殊性,因為只有0和1的編碼,那麼我們就可以直接建一個二叉樹,0在左子樹,1在右子樹。然後DFS,判斷葉子的個數,因為如果有字首的編碼,那麼最後的葉子個數一定小於編碼的個數。

過程:

  • 首先宣告結點結構體:
struct Node{
    int v;
    Node *left, *right;
    bool known;
    Node():known(false), left(NULL), right(NULL){}
};
  • 建樹過程:
void build(Node *root, char *str)
{
    Node *u = root; 
    for(int i=0; i<strlen(str); i++)
    {
        if(str[i]=='0')
        {
            if(u->left==NULL) u->left = newnode();  //遇0向左結點走 
            u = u->left; 
        }else if(str[i]=='1')
        {
            if(u->right==NULL) u->right = newnode();//遇1向右結點走 
            u = u->right;
        }
        u->v = str[i]-'0';//此行可有可無,因為是為了除錯建樹是否正確才給0或1的值的,如果只是計算葉子的個數,就無需此步。
    }
    return;
}
  • 判斷是否為字首(計算葉子數)
    因為葉子沒有左右孩子。用k統計葉子數
void decodable(Node *root, int &k)
{
    Node *u = root;
    if(u->left!=NULL && u->left->known == false)
    {
        u->left->known = true;
        decodable(u->left, k); //DFS
    }
    if(u->right!=NULL && u->right->known == false)
    {
        u->right->known = true;
        decodable(u->right, k);//DFS
    }
    if(u->left == NULL && u->right == NULL) k++;//關鍵,如果左右孩子沒有,則葉子數加一。
}

完整程式碼:

#include<cstdio>
#include<cstring>
using namespace std;

struct Node{
    int v;
    Node *left, *right;
    bool known;
    Node():known(false), left(NULL), right(NULL){}
};

Node *newnode()
{
    return new Node();
}

void build(Node *root, char *str)
{
    Node *u = root; 
    for(int i=0; i<strlen(str); i++)
    {
        if(str[i]=='0')
        {
            if(u->left==NULL) u->left = newnode();  //遇0向左結點走 
            u = u->left; 
        }else if(str[i]=='1')
        {
            if(u->right==NULL) u->right = newnode();//遇1向右結點走 
            u = u->right;
        }
        u->v = str[i]-'0';
    }
    return;
}

void decodable(Node *root, int &k)
{
    Node *u = root;
    if(u->left!=NULL && u->left->known == false)
    {
        u->left->known = true;
        decodable(u->left, k);
    }
    if(u->right!=NULL && u->right->known == false)
    {
        u->right->known = true;
        decodable(u->right, k);
    }
    if(u->left == NULL && u->right == NULL) k++;
}

int main()
{
    char str[12];
    Node *root = newnode();
    int k = 0;
    int count = 0;
    int kase = 0;
    while(gets(str))
    {
        if(str[0]!='9')
        {
            count++;
            build(root, str);
        }
        if(str[0]=='9'){
            decodable(root, k);
            if(k == count)
            {
                printf("Set %d is immediately decodable\n",++kase);
            }else{
                printf("Set %d is not immediately decodable\n",++kase);
            }
            root = newnode();
            count = k = 0;
        }
    }
    return 0;
} //已AC。