1. 程式人生 > >Piggy-Bank-完全揹包問題

Piggy-Bank-完全揹包問題

Piggy-Bank

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2940    Accepted Submission(s): 1452

Problem Description Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. 

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! Input The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams. Output Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.". Sample Input 3 10 110 2 1 1 30 50 10 110 2 1 1 50 30 1 6 2 10 3 20 4 Sample Output The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.

This is impossible.

大概意思就是:有一個存錢罐,告知你其空時的重量和當前重量,並給定一些錢幣的價值和相應的重量,問存錢罐中最少有多少現金? 思路:由於每個錢幣都可以有任意多,所以該問題為完全揹包問題,要求我們在狀態轉移時,在dp[j]和dp[j-list[i].w]+list[i].v]中選擇一個較小的作為值,其次,要求錢幣重量和空餘的重量要恰好達到總重量。 程式碼:
#include<stdio.h>
#include<algorithm>
using namespace std;
#define INF 0x7fffffff
struct E{
	int w,v;
}list[500];

int dp[1001];

int main()
{
	int n;
	scanf("%d",&n);
	while(n--){
		int s,tmp;
		scanf("%d%d",&tmp,&s);
		s-=tmp; //計算差額重量,也就是錢幣的重量
		int num;
		scanf("%d",&num);
		for(int i=1;i<=num;i++){
			scanf("%d%d",&list[i].v,&list[i].w);
		}
		for(int i=1;i<=s;i++) //因為要求剛好裝滿,所以其他的取不到都賦值為無窮
			dp[i]=INF;
		dp[0]=0;
		for(int i=1;i<=num;i++)//完全揹包。順序遍歷所以可能轉移的狀態
			for(int j=list[i].w;j<=s;j++){ 
				if(dp[j-list[i].w]!=INF) //若不為負無窮,就是說這個可以取到
				dp[j]=min(dp[j],dp[j-list[i].w]+list[i].v);
			}
		if(dp[s]!=INF) //存在就輸出
		   printf("The mininim amount of money in the piggy-bank is %d\n",dp[s]);
		else
			printf("This is impossible!");
	}
	return 0;
}