[hdu 5534]2015ACM/ICPC亞洲區長春站 Partial Tree 完全揹包
Partial Tree
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 674 Accepted Submission(s): 331
Problem Description
In mathematics, and more specifically in graph theory, a tree is an undirected graph in which any two nodes are connected by exactly one path. In other words, any connected graph without simple cycles is a tree.
You find a partial tree on the way home. This tree has n nodes but lacks of n−1 edges. You want to complete this tree by adding n−1 edges. There must be exactly one path between any two nodes after adding. As you know, there are nn−2 ways to complete this tree, and you want to make the completed tree as cool as possible. The coolness of a tree is the sum of coolness of its nodes. The coolness of a node is f(d), where f is a predefined function and d is the degree of this node. What’s the maximum coolness of the completed tree?
Input
The first line contains an integer T indicating the total number of test cases.
Each test case starts with an integer n in one line,
then one line with n−1 integers f(1),f(2),…,f(n−1).
1≤T≤2015
2≤n≤2015
0≤f(i)≤10000
There are at most 10 test cases with n>100.
Output
For each test case, please output the maximum coolness of the completed tree in one line.
Sample Input
2
3
2 1
4
5 1 4
Sample Output
5
19
Source
2015ACM/ICPC亞洲區長春站-重現賽(感謝東北師大)
題意:
給一棵n個點的樹新增邊,給定度函式f(d)為一個點的度的函式,求所有點的度函式的最大和
思路:
樹,所以每個點至少1個度;
然後dp作n-2個度;剩下n-2的度分給n個點
揹包價值變成v[i]=v【i】-v【1】;
dp[i]代表i個度的最優值
dp[i+j-1] = max(dp[i+j-1], dp[j] + F[i]);
程式碼:
#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int T;
int ans;
int dp[2200];
int f[2200];
int n;
int solve(int m)
{
for(int i=1;i<=n-2;i++) dp[i]=-99999999;
dp[0]=0;
for(int i=2;i<=n-1;i++)
for (int j=0; j+i-1<=n-2;j++)
dp[i+j-1]=max(dp[i+j-1],dp[j]+f[i]);
return dp[n-2];
}
int main()
{
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
for(int i=1;i<n;i++) scanf("%d",&f[i]);
ans=n*f[1];
for(int i=2;i<n;i++) f[i]-=f[1];
printf("%d\n",ans+solve(n-2));
}
}