POJ 1995 Raising Modulo Numbers (快速冪 +同餘定理)
阿新 • • 發佈:2019-02-19
Raising Modulo Numbers
Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given moment all players show their numbers to the others. The goal is to determine the sum of all expressions AiBi from all players
including oneself and determine the remainder after division by a given number M. The winner is the one who first determines the correct result. According to the players' experience it is possible to increase the difficulty by choosing higher numbers.
You should write a program that calculates the result and is able to find out who won the game.
The input consists of Z assignments. The number of them is given by the single positive integer Z appearing on the first line of input. Then the assignements follow. Each assignement begins with line containing an integer M (1 <= M <= 45000). The sum will be
divided by this number. Next line contains number of players H (1 <= H <= 45000). Next exactly H lines follow. On each line, there are exactly two numbers Ai and Bi separated by space. Both numbers cannot be equal zero at the same time.
For each assingnement there is the only one line of output. On this line, there is a number, the result of expression
Time Limit: 1000MS | Memory Limit: 30000K |
Total Submissions: 6444 | Accepted: 3794 |
Description
People are different. Some secretly read magazines full of interesting girls' pictures, others create an A-bomb in their cellar, others like using Windows, and some like difficult mathematical games. Latest marketing research shows, that this market segment was so far underestimated and that there is lack of such games. This kind of game was thus included into the KOKODáKH. The rules follow:Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given moment all players show their numbers to the others. The goal is to determine the sum of all expressions AiBi
You should write a program that calculates the result and is able to find out who won the game.
Input
Output
(A1B1+A2B2+ ... +AHBH)mod M.
Sample Input
3 16 4 2 3 3 4 4 5 5 6 36123 1 2374859 3029382 17 1 3 18132
Sample Output
2 13195 13
Source
題意:給出T代表T組測試資料,再輸入一個M,一個N,接下來有N組資料 a ,b,求這N組資料a的b次冪的和對M取餘的結果 思路:快速冪+同餘定理。#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int mod(int a,int b,int c)
{
int res=1%c;
int t=a%c;
while(b)
{
if(b%2)
{
res=res*t%c;
}
t=t*t%c;
b=b/2;
}
return res;
}
int main()
{
int t,m,n,a,b,i,j,k,l;
scanf("%d",&t);
while(t--)
{
scanf("%d",&m);
scanf("%d",&n);
int sum=0;
for(i=0;i<n;i++)
{
scanf("%d%d",&a,&b);
sum+=mod(a,b,m);
}
printf("%d\n",sum%m);
}
return 0;
}